Support » Installing WordPress » Error whilst install.php: Table ‘wordpress.wp_options’ doesn’t exist

  • Hi together,

    I’m trying to install WP 6.0 EN on Windows 2022 Server Datacenter Edition with IIS 10 (Build 10.0.20348.1), PHP 8.1.6 and MySQL 8.0. I created the tatabase wordpress in MySQL and I’m using the user “root” in the wp_config.phph. When I’m running install.php the database connection can be established correctly (when I missspell the password I’m getting a regular error maessage). Instead of installing WordPress I’m getting the following error:

    WordPress database error Table ‘wordpress.wp_options’ doesn’t exist for query INSERT INTO wp_options (option_name, option_value, autoload) VALUES (‘nonce_key’, ‘q(zaaYeY9N37V#n-q@/%?-DHt(Uv4l^Dj5f(&OH?t3g-fbyw#Y>r /0~%~i@i+M', 'no') ON DUPLICATE KEY UPDATEoption_name= VALUES(option_name),option_value= VALUES(option_value),autoload= VALUES(autoload`) made by wp_can_install_language_pack, WP_Upgrader->fs_connect, Automatic_Upgrader_Skin->request_filesystem_credentials, WP_Upgrader_Skin->request_filesystem_credentials, request_filesystem_credentials, wp_nonce_field, wp_create_nonce, wp_hash, wp_salt, update_site_option, update_network_option, add_network_option, add_option

    Tried to debug and fix the problem using XDebug, but couldn’t find the reason for that so far.

    Does anybody has a solution for that problem?

    Before WP 6.0 I also tried it with WP 5.9.1 DE, same problem.

    Many tx in advance

Viewing 4 replies - 1 through 4 (of 4 total)
  • Jorge Luiz

    (@jluizsouzadev)

    I highly recommend you to log in MySQL server, and delete the WordPress database. Then, try to reinstall WP from scratch.

    References:

    https://forums.cpanel.net/threads/database-error-while-trying-to-install-wordpress-on-windows.91017/

    • This reply was modified 1 month, 1 week ago by Jorge Luiz.
    • This reply was modified 1 month, 1 week ago by Jorge Luiz. Reason: grammar fixing
    Thread Starter stillrooky

    (@stillrooky)

    Hola Jorge,

    muchas gracias for your very fast advice.

    I tried it out,
    – deleted the database/schema
    – created a new one
    – user root has full access rights

    but the problem is still the same.

    Checked the error-log, found that the service account “Network Service” used for MySQL-service didn’t had rights to access the log-files, changed the service account to “Local System Account”, error log didn’t show the problem any more.

    Tried again install.php, still the same problem.

    Content of error-log of MySQL:

    2022-07-03T08:05:33.925737Z 0 [Warning] [MY-000081] [Server] option 'read_buffer_size': unsigned value 3072 adjusted to 8192.
    2022-07-03T08:05:33.925832Z 0 [Warning] [MY-010915] [Server] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.
    2022-07-03T08:05:33.928149Z 0 [System] [MY-010116] [Server] C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe (mysqld 8.0.29) starting as process 6796
    2022-07-03T08:05:33.953618Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
    2022-07-03T08:05:36.340002Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
    2022-07-03T08:05:37.428294Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
    2022-07-03T08:05:37.428796Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
    2022-07-03T08:05:37.523719Z 0 [System] [MY-010931] [Server] C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe: ready for connections. Version: '8.0.29'  socket: ''  port: 3306  MySQL Community Server - GPL.
    2022-07-03T08:05:37.524683Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '::' port: 33060

    content of general-log

    C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe, Version: 8.0.29 (MySQL Community Server - GPL). started with:
    TCP Port: 3306, Named Pipe: MySQL
    Time                 Id Command    Argument
    C:\Program Files\MySQL\MySQL Server 8.0\bin\mysqld.exe, Version: 8.0.29 (MySQL Community Server - GPL). started with:
    TCP Port: 3306, Named Pipe: MySQL
    Time                 Id Command    Argument

    What else can I do?

    A couple of days ago I found another post regarding that problem:

    https://wordpress.org/support/topic/wordpress-database-error-table-wp_options-doesnt-exist-2/

    This guy seems to know the solution, but didn’t explain it. He seems to work in WordPress-support also sometimes. Maybe you can bring me in contact with him?

    Saludos cordiales (and a bit desperate they are meanwhile also :-))

    Andreas

    Thread Starter stillrooky

    (@stillrooky)

    Addition: maybe the general logging was not activated correctly in the previous attemps, now I’m getting that (despite of that still the same problem, same error messages, the tables are not created and I dont get the set-up-form:

    [Large code excerpt removed by moderator per our FAQ. Please use Pastebin or a Gist for all large code excerpts, they work better anyway.]

    • This reply was modified 1 month, 1 week ago by Yui.
    Jorge Luiz

    (@jluizsouzadev)

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.