Support » Plugin: EWWW Image Optimizer » Error while uploading

  • Resolved Patrik

    (@patschi)


    Always when I upload any picture (tested with .png and .jpg), I get following error:

    Warning: Invalid argument supplied for foreach() in /var/www/blog/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 1096

    But when I take a look into the mediathek, the image got reduced. Programs are installed.

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Is this on a production server? I ask because you only see those errors in DEBUG mode, which should not be enabled on a production server. At any rate, the warning will go away with 1.2.2, due out today.

    It’s on my own server with PHP 5.4. I also noticed, when I enable the plugin the XMLRPC API for uploading pictures to the mediathek won’t work.

    Thanks for your response 🙂

    Plugin Author nosilver4u

    (@nosilver4u)

    Sorry, should have said ‘production site’. And it’s a setting in wp-config.php that I’m referring to that tells wordpress to output notices and warnings to the browser for debugging.

    Debug seems to be disabled:

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);
    define('DISABLE_WP_CRON', true);

    Seems to work since the last version – Thanks 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error while uploading’ is closed to new replies.