Support » Plugin: wpDirAuth » Error while upgrading from 1.7.6 to 1.8.1

  • Resolved hatama17

    (@hatama17)


    Can’t seem to upgrade from 1.7.6 to 1.8.1 I am getting the following error when using the update utility within the dashboard.

    wpDirAuth: Parse error: syntax error, unexpected T_FUNCTION in /www/…./wp-content/plugins/wpdirauth/wpDirAuth.php on line 2100

    Thanks in advance,

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Paul Gilzow

    (@gilzow)

    what version of PHP are you running on the server where this error occurs?

    5.2.5 version

    Plugin Author Paul Gilzow

    (@gilzow)

    That’s the reason. You have probably heard this before but I feel obligated to at least mention it: PHP 5.2.5 was released almost 10 years ago, and reached End-of-Life over 7 years ago. I’m not sure who you are using for hosting but you really should consider getting PHP updated.

    For this version of wpDirAuth, you can change line 2100 to

    add_action('lostpassword_form',create_function('','echo get_site_option("dirAuthChangePassMsg");'));

    And it will work. HOWEVER, moving forward, i’ll probably only support v5.3.X+ of PHP.

    • This reply was modified 1 year, 2 months ago by  Paul Gilzow.

    Thanks a lot for your answer

    Plugin Author Paul Gilzow

    (@gilzow)

    I just released version 1.9.3 where i re-added support for v5.2.X of PHP. Once I start on v2.0 of wpDirAuth I’ll probably only support 5.3+ of PHP.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error while upgrading from 1.7.6 to 1.8.1’ is closed to new replies.