Support » Installing WordPress » Error while trying to install WordPress

  • Hi!

    This is my first time working with WordPress and I’m having issues installing WordPress on a website. I’m using FTP to do so. I’ve transferred all the files from the wordpress download on there (all the files inside the ‘wordpress’ directory onto root). I keep getting the following error every time I try running the mysite.com/wp-admin/install.php :

    Warning: require_once() [function.require-once]: Unable to access ./wp-load.php in /home/(my user)/wp-admin/install.php on line 36
    
    Warning: require_once(./wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/(my user)/wp-admin/install.php on line 36
    
    Fatal error: require_once() [function.require]: Failed opening required './wp-load.php' (include_path='.:/usr/local/lib/php') in /home/(my user)/wp-admin/install.php on line 36

    Specs:
    Windows 10, Chrome, FileZilla for file transfer, PHP7, WordPress 5.6

    Any ideas of how I could fix that?

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • A clue is

    Unable to access

    It is possible that your file permissions are such that the web server can not read the uploaded files.

    Changing File Permissions

    Jitin Mishra

    (@simpleintelligentsystems)

    This looks like a permission issue with the files. When files are uploaded using FTP, the owner of the files is the FTP user. When you are running the setup, the web server (a different user) is not able to read the files.

    Thread Starter justinerjt

    (@justinerjt)

    Hi, so I’ve tried to change permissions. I looked around, and the general consensus seemed to be 755 for directories and 644 for files. I think they were already preset to that. I still retyped it in to be sure (first on Filezilla, then on my host’s FTP client), but I’m still getting the exact same message. I tried setting full permissions to the wp-load.php file since it seems to be the problem (I switched it back right after, I know it can be a security hazard.) but the message is still the exact same. Not sure what to do…

    Jitin Mishra

    (@simpleintelligentsystems)

    Hi,
    You can try to set 775 for the directories and 664 for the files. If that does not even, then you should contact your host to find out the correct permissions for the filesystem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error while trying to install WordPress’ is closed to new replies.