WordPress.org

Forums

Genesis eNews Extended
[resolved] Error while setting up AWeber in a form with only an email field (5 posts)

  1. hashimnaushahi
    Member
    Posted 10 months ago #

    Hi Brandon,

    Thank you for offering amazing support!

    I didn't know anything about working with forms. And I'm also totally new with AWeber. I first looked through all the entries containing 'AWeber' in the topic. And thanks to that I found this great tutorial:

    http://www.brandonkraft.com/uploads/enews-aweber-draft.pdf

    But while testing the form I get this error saying:

    Required Fields Are Missing

    Name
    Email

    Please fill in the missing information.

    The form has got just one field for an email address. You can see it on my website:

    http://hashimnaushahi.com

    And you can see it even better in the demo of the StudioPres theme:

    http://demo.studiopress.com/generate/

    So basically my question is what I did wrong. And I really hope you can help me out. Thank you in advance!

    Sincerely,

    Hashim Naushahi

    https://wordpress.org/plugins/genesis-enews-extended/

  2. hashimnaushahi
    Member
    Posted 10 months ago #

    Hi Brandon,

    Forget my request for your support. It's working perfectly now!

    I recreated the webform and deleted the name field from it. And I changed 'Email' to 'email' as you've stated many times before in previous support requests. After that, I copied the new code and pasted that into the hidden fields section of the widget.

    It still didn't work after that. But that was because I forget to refresh the page I was testing from. ;)

    Thank you, Brandon!

    Sincerely,

    Hashim Naushahi

  3. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I'm glad I could help (in the past threads at least!)

    Cheers!

  4. bvwright@gmail.com
    Member
    Posted 6 months ago #

    Hi Brandon,

    I've read through I think every single forum post on WordPress.org that you've written on the "Required Fields Missing" issue, but I cannot find out what's causing my own problem.

    My site is at http://www.bridgetwright.com

    My site is updated with WordPress 4.0.

    I've installed the Genesis news extended plugin and put in the information from Aweber in the different fields.

    I've also deleted (removed) the widget plugin twice from my sidebar in an effort to clear up the problem.

    When I test the subscription box with my name and email, I get an error message that says:

    Required Field Are Missing
    email

    AND

    Required Field Are Missing
    name, email

    Yes, the error message vacillates between the two messages, even though nothing changes.

    Here's what I'm putting into the fields:
    ____________________
    Form Action: http://www.aweber.com/scripts/addlead.pl
    E-mail Field: email
    (I've made it lowercase & uppercase to see if it will work. I read where you said that it needs to be lowercase though so I kept it there after the 3rd try).
    First Name Field: name
    (Did the same thing here with the upper/lower on the letter)
    Last Name Field: name
    Hidden Fields:
    <div style="display: none;">
    <input type="hidden" name="meta_web_form_id" value="4092xxxxx" />
    <input type="hidden" name="meta_split_id" value="" />
    <input type="hidden" name="listname" value="awlist36xxxxx" />
    <input type="hidden" name="redirect" value="http://www.aweber.com/thankyou-coi.htm?m=text" id="redirect_125113ed0ae6ab22a42e5e3b96a7d508" />

    <input type="hidden" name="meta_adtracking" value="Blogging_Newsletter" />
    <input type="hidden" name="meta_message" value="1" />
    <input type="hidden" name="meta_required" value="name, email" />

    <input type="hidden" name="meta_tooltip" value="" />
    </div>

    First Name Input Text: First Name
    Last Name Input Text: Last Name
    E-Mail Input Text: E-Mail Address
    Button Text: Go
    ____________________________

    I've pored over your instructions and I keep on getting this error message that "Required Fields Are Missing."

    Any idea??

  5. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 3 months ago #

    Hi bvwright,

    Sorry for the delay. I've been out and this was buried in an existing thread. The initial thing I notice is that you're using two fields both with "name". Honestly, I'm not sure what the result of that will be.

    Otherwise, that's the only issue I see from the above.

    Cheers!

Reply

You must log in to post.

About this Plugin

  • Genesis eNews Extended
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic