Support » Plugin: Pixel Caffeine » Error while generating a Facebook Feed

  • Resolved eadvertising

    (@eadvertising)


    Hello, I have this error while I am trying to generate a feed for Facebook, using an existing catalog.

    Argument 1 passed to PixelCaffeine\ProductCatalog\Admin\Metaboxes::get_google_category() must be an instance of WP_Post, null given, called in /public_html/wp-content/plugins/pixel-caffeine/includes/supports/class-aepc-woocommerce-addon-support.php on line 433

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Antonino Scarfì

    (@antoscarface)

    Hi,

    sorry for the issue. I fixed it and it’s already ready for the next version of the plugin together with some other fixes.

    If you want to fix immediately, please get the version with the fix from the link below and replace with the one you have. The fix will be released with the new version, so when you will update you won’t do anything to re-apply the patch.

    Here the link: https://www.dropbox.com/s/k40nfrd9ztznydx/pixel-caffeine.2.0.0.google-fix.zip?dl=0

    Thank you.

    Awesome, I will test and I will be bAck with a feedback.
    Also, this plug-in loads the thumbnail of the product. It would be great if I can choose what size to load. Thanks

    It’s working, but it’s loading the image at 127px ( this is set for thumbnail )
    On the previous version I did change the image size, on that function, but now you changed the structure of the plugin.
    Can you guide me how to load the url to full size image?

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Hi,

    glad that the first issue is fixed. About the second thing, unfortunately, there isn’t an easy way to change the size of the thumbnail selected for the feed.

    I could suggest you how to make the fix in the plugin, it will be replaced with the official fix I will implement in the next version.

    Open the file wp-content/plugins/pixel-caffeine/includes/supports/class-aepc-woocommerce-addon-support.php and go to the line 420, you should find this line:
    ->set_image_url( preg_replace( '/.*src="([^"]+)".*/', '$1', $product->get_image() ) )

    Replace it with:
    ->set_image_url( preg_replace( '/.*src="([^"]+)".*/', '$1', $product->get_image('large') ) )

    After this, refresh the feed file from the “Product catalog” admin page and you should have the image with the largest format.

    I hope that helps you.

    Let me know.

    Awesome, thanks

    Hi, now I got
    The file xml it seems not existing. Click into the “Try Again” button in order to refresh it!
    I downloaded the version that it was available on another support thread, but the problem is still there…

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Hi @eadvertising,

    please, continue the XML error in the other thread, so to take order in the threads, thank you.

    Regarding the thumbnail size issue is fixed for you? So, I can mark this issue as fixed.

    Additionally, I will add also a new option in the feed configuration in the next version of the plugin (already set with “full” size as value), so you will be able to upgrade without changes to do.

    Honestly, I can’t tell if it’s fixed, because I don’t have that XML file.

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Just to understand: were you able to create the feed XML at least once? I’m referring to your message about the image size. Not sure if you asked to choose the size because you see the wrong URL to the image inside the feed or it’s something you asked disregarding the XML result.

    The XML was having the same images with 127×127 so I deleted that XML file and made one from 0
    Then I got that error.

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Got it.
    Just for your information, next time you just need to click the “Refresh” button in order to refresh it. It automatically replaces the XML file with the new one 🙂

    Now, another question: have you tried to click the “Try again” button? Nothing happens?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error while generating a Facebook Feed’ is closed to new replies.