• Resolved ghabhishek

    (@ghabhishek)


    After activating the plugin, WordPress shows “Sorry, you are not allowed to access this page.” message with Query Monitor saying:

    The message above was triggered by Core.
    
    Call stack:
    
    wp_die()
    wp-admin/includes/menu.php:350

    Also, after manually opening the admin page, the plugin shows this error:

    Your PHP setting memory_limit is currently set to 2G. We recommand to set this value at least to 128M to avoid any issue with our plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Hermann LAHAMI

    (@mano88)

    Hello,
    Is woocommerce active?

    Thread Starter ghabhishek

    (@ghabhishek)

    HI,

    Yes, WooCommerce is active.

    Plugin Author Hermann LAHAMI

    (@mano88)

    Can you provide a screenshot?

    Thread Starter ghabhishek

    (@ghabhishek)

    Sure.
    Video: https://i.imgur.com/M7WXmc8.gifv
    Screenshot: https://i.imgur.com/u6rgHoL.png

    • This reply was modified 1 year, 2 months ago by ghabhishek.
    Plugin Author Hermann LAHAMI

    (@mano88)

    Are you logged as admin?

    If you are, can you run a quick conflict test by:

    1-disabling all other plugins except woocommerce and our plugin
    2-switching the theme to one of the defaults such as twenty sixteen
    3-and try again. If everything is working as expected, that means we have a conflict somewhere so you can start re enabling the disabled items one by one in order to find the culprit.
    4-once you do, please let us know so we can start the inspection.

    Thread Starter ghabhishek

    (@ghabhishek)

    Dear Team,

    This is still the case with a new blank installation on a different server.

    Plugin Author Hermann LAHAMI

    (@mano88)

    @ghabhishek I’m confused. Are we talking about the message “Sorry, you are not allowed to access this page.” or about this: https://i.imgur.com/u6rgHoL.png?

    Thread Starter ghabhishek

    (@ghabhishek)

    @mano88 both, the message “Sorry, you are not allowed to access this page.” comes right after activation and then when you manually go to the /wp-admin you get to see the above notices.

    You can see all this here: https://imgur.com/M7WXmc8

    Plugin Author Hermann LAHAMI

    (@mano88)

    The notices are normal. Some requirements are needed for the plugin to generate data properly. I suggest you adjust your php.ini file if you’re familiar with it. if not, please contact your server admin for that.

    Regarding the message we’ll work on it. But it’s not a blocking issue.

    Thread Starter ghabhishek

    (@ghabhishek)

    It is understandable that the plugin would ask the user for the minimum required memory limit but as seen form the screenshot shared earlier(), we already have 2 GB of memory configured in the php.ini while the plugin is only asking for 128 MB which is way lower than the already provided memory so logically it shouldn’t ask us to increase the memory limit if the requirements are already met.

    Plugin Author Hermann LAHAMI

    (@mano88)

    Oh my bad. Ok please ignore that issue while we fix it. It’s a mistake from the plugin…

    Thread Starter ghabhishek

    (@ghabhishek)

    Sure, please take a look at the issue. Would be waiting for an update. Is the first issue also related to the same memory notice issue?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error while activating the plugin’ is closed to new replies.