Support » Plugin: Events Manager » Error while activating the plugin

  • Resolved paxol

    (@paxol)


    When I activate the latest version of Events Manager I get this error:
    Fatal error: Cannot use object of type WP_Error as array in /var/www/vhosts/420hempfest.com/httpdocs/wp-content/plugins/wpml-translation-management/inc/actions/wpml-tm-post-actions.class.php on line 192

    I’m on the latest version of WPML.
    WP Version: 5.0.3
    PHP Version: 5.6.40

    Also tried with PHP 7, same error:
    Fatal error: Uncaught Error: Cannot use object of type WP_Error as array in /var/www/vhosts/420hempfest.com/httpdocs/wp-content/plugins/wpml-translation-management/inc/actions/wpml-tm-post-actions.class.php:192 Stack trace: #0 /var/www/vhosts/420hempfest.com/httpdocs/wp-content/plugins/wpml-translation-management/inc/actions/wpml-tm-post-actions.class.php(50): WPML_TM_Post_Actions->save_translation_priority(4421) #1 /var/www/vhosts/420hempfest.com/httpdocs/wp-content/plugins/wpml-translation-management/inc/wpml-private-actions.php(65): WPML_TM_Post_Actions->save_post_actions(4421, Object(WP_Post), false) #2 /var/www/vhosts/420hempfest.com/httpdocs/wp-includes/class-wp-hook.php(286): wpml_tm_save_post(4421, Object(WP_Post), false) #3 /var/www/vhosts/420hempfest.com/httpdocs/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /var/www/vhosts/420hempfest.com/httpdocs/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /var/www/vhosts/420hempfest.com/httpdocs/wp-content/plugins/sitepress-multiling in /var/www/vhosts/420hempfest.com/httpdocs/wp-content/plugins/wpml-translation-management/inc/actions/wpml-tm-post-actions.class.php on line 192

    • This topic was modified 2 months, 2 weeks ago by  paxol.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support timrv

    (@timrv)

    Hello,

    I have noticed that you have already tried on PHP 7, Please stick with PHP 7. Can you perhaps disable the plugin called “wpml-translation-management” or can you make sure you’re using the latest versions for both plugins? The error that is showing is based on that plugin and not from Events Manager.

    Hello,

    Tanks for your reply.
    I disabled all wpml plugins, than activated Events Manager and after re-activated all wpml plugin and it works.
    Tanks for your time!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.