Support » Plugin: CATS Job Listings » Error while activating plugin

  • Resolved chandrakantmk

    (@chandrakantmk)


    Hi,

    I am trying to pull job listings to my WordPress website. I have installed your WordPress plugin “CATS Job Listings”. But, when I click on plugin’s “Activate” link, the plugin doesn’t activates and it shows the following message which appears at the top of Plugins page:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_FUNCTION in /…/wp-content/plugins/cats-job-listings/CatsJobListingAdmin.php on line 73

    Please advice.

Viewing 5 replies - 1 through 5 (of 5 total)
  • That’s a typical error if the version of PHP running on your server is too old. The plugin will only work with PHP 5.3+. Older version of PHP have not been supported for some time and contain security risks. We always recommend upgrading to the latest version of PHP when possible.

    Thread Starter chandrakantmk

    (@chandrakantmk)

    Hi,

    Thanks for your reply.

    The PHP Version on my server is already 5.4.45

    Screenshot: https://www.screencast.com/t/XY7ELJCsnsv

    Please advice.

    That’s very odd, because that error is definitely regarding functionality that every version of PHP 5.3 and newer should have. I just tested the plugin on PHP 5.4 myself and am not getting that error, as I would expect.

    I’ll continue to look at possible reasons it wouldn’t be working for you, but all signs definitely seem to be pointing to something strange going on with your version of PHP. Perhaps, you have multiple versions installed on your server, and the wrong one is being used in this case?

    Thread Starter chandrakantmk

    (@chandrakantmk)

    Hi,

    Yes, there are multiple versions of PHP installed on my server. But the PHP version 5.4.45 is installed for the WordPress website for which I would like to use this plugin.

    Request you to provide some solution to help me activate this plugin and get rid of that error.

    Thread Starter chandrakantmk

    (@chandrakantmk)

    Hi,

    The root website’s PHP Version upgrade to 5.4 have fixed this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error while activating plugin’ is closed to new replies.