WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Error when upgrading

[Resolved] Error when upgrading

  • I am trying to upgrade from 1.2.39.3 to 1.9.6.1 and when I try to activate the newer version I get this error –
    Fatal error: Cannot redeclare plugin_prevent_upgrade() (previously declared in /mnt/stor08-wc1-ord1/744664/test.thepurebar.com/web/content/wp-content/plugins/store-locator/store-locator.php:36) in /mnt/stor08-wc1-ord1/744664/test.thepurebar.com/web/content/wp-content/plugins/store-locator-new/store-locator.php on line 52

    http://wordpress.org/extend/plugins/store-locator/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Viadat

    @viadat

    Try v1.9.6.2 .. sounds like another plugin may have the same function. Also try deactivating the plugin first, upgrading it, then reactivating it .. see if that does the trick.

    The weird thing is that the older version is definitely working, but it doesn’t show up in the plugin list, or I would have tried that first. Should I try deleting the old one from the plugins directory?

    Plugin Author Viadat

    @viadat

    Interesting — make sure you’re actually viewing ‘all’ of your plugins, and you’re not just viewing ‘active’, ‘inactive’, ‘recently active’ or ‘update available’ plugins.

    As long as you’ve moved any of your customizations (CSS, images, translations, etc.) to ‘wp-content/uploads/sl-uploads/’ you should be fine deleting, then installing the latest version

    Yes, I checked that a couple of times. It is really odd. The only one that shows up is the new one, which is not active yet.

    Plugin Author Viadat

    @viadat

    Another way to deactivate the older version, since you’re not seeing it, is to rename the older ‘store-locator’ folder to something like ‘store-locator.old’ and then re-visit the Plugins page of your WP admin area ..

    Then, a highlighted message saying that the plugin was deactivated should usually appear a the top, because it couldn’t be found under it’s original folder name.

    That seems like it worked. Thanks for the help. Now I have one last thing I am trying to do. I need to do a bulk import or update. Is there an easy way to do that?

    One other thing, on both this version and the old one, the Manage locations page has no results, and I can’t figure out if there is something I should do to show results. If I change the locations per page, and click change, i still don’t see results. If i click the show un-geocoded locations (369) I also don’t see any results.

    Plugin Author Viadat

    @viadat

    Contact us via our website .. All these issues seem like something unique to your server/setup

    I just responded in your form on your site. Thanks for the help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Error when upgrading’ is closed to new replies.