WordPress.org

Support

Support » How-To and Troubleshooting » Error when upgrading to WP2.8

Error when upgrading to WP2.8

  • Got this error when I upgraded automatically from 2.7.1 to 2.8:

    Warning: gzinflate() [function.gzinflate]: data error in /home/acctname/public_html/wp-includes/http.php on line 1787

    I don’t know what the effect is, everything seems to be running fine, but I got this error on all my WP blogs. Also, after the upgrade, WP didn’t ask to upgrade the database….

Viewing 15 replies - 1 through 15 (of 57 total)
  • I receive similar errors on all of the dashboard pages The blog itself looks fine:

    Warning: gzinflate() [function.gzinflate]: data error in C:\xampp\htdocs\wordpress\wp-includes\http.php on line 1787
    
    Warning: gzuncompress() [function.gzuncompress]: data error in C:\xampp\htdocs\wordpress\wp-includes\http.php on line 1792
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\wordpress\wp-includes\http.php:1787) in C:\xampp\htdocs\wordpress\wp-includes\functions.php on line 784
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\wordpress\wp-includes\http.php:1787) in C:\xampp\htdocs\wordpress\wp-includes\functions.php on line 785

    I’ve tried deactivating and removing all plugins, and switching to the default theme, with no affect.

    I wonder if the theme has something to do with this. I use WooThemes on all my blogs. Can’t figure it out yet though…

    Not exactly the same thing but look at https://core.trac.wordpress.org/ticket/10104 and try this:

    Download this and install it over wp-includes/http.php.
    http://core.trac.wordpress.org/export/11450/trunk/wp-includes/http.php

    OK! I am sorry to do this, but can someone please help me with my recent post about headers and editing!

    I am getting the same error in my sidebar. I think it’s due to the theme I’m using which has Twitter function.

    Here’s a screenshot:
    http://kttns.org/kzzgy

    I’ve tried replacing the original http.php with the mentioned http.php but it’s still there.

    Can someone suggest how I can fix this? I am not very familiar with the coding.

    These error messages relate to some new functions for deflate and gzip transfer encodings. They appear to be indicating that the upgrade package has not been able to be correctly unzipped.

    To recover from this, just temporarily deactivate your plugins, do a backup, and do a manual upgrade of 2.8. The manual upgrade will check to see if your database has already been upgraded and, if it hasn’t been, it will take you to the database upgrade.

    Don’t ignore these errors because its highly likely that you have not got a complete install of 2.8 yet.

    Hope this helps.

    Elpie, thanks very much! Manual upgrading seems to work for me. No more of this error.

    Just replacing the http.php in the /wp-includes dir like MichaelH suggested worked perfectly for me.

    Give it a try before you do a full reinstall

    I only receive the warnings from last.fm for WordPress plugin, so I’ve disabled it for the time being.
    Replacing the http.php didn’t make the errors go away for me.

    I am having the same issue as paulbm-uk. That plugin is broken for me in two separate installs of 2.8

    The last.fm plugin is old and is clearly not compatible with WordPress 2.8. I suspect it just might be updated soon though as the developer’s own site has that same error showing on it 😉
    I’d recommend uninstalling it and waiting for an updated plugin.

    I’m on it, but I have no clue about what can be happening…

    I tried to perform an instant upgrade to WP 2.8 and my process page said “done” even though there was no indication that the different steps (downloading upgrade file etc) were being completed. I refreshed and nothing changed so I thought maybe my IE browser wasn’t responding. I closed the tab and when I returned to the wp admin url, I received the following error instead of the sign in form:

    Fatal error: Call to undefined method WordPress_Module::_weak_escape() in /home/majorla/public_html/wp-includes/wp-db.php on line 487

    I am unable to sign into my dashboard at all and my home page also shows this error.

    My hosting control panel works as does the site’s email. How do I restore the backup or otherwise obtain access to my dashboard?

    I was unable to gain access through FileZilla as well. I get the following error through FileZilla

    530 Login authentication failed

    Thanks,

    Laura

    My hosting company moved a plugin and I was able to install my backfile files with Filezilla by using the control panel webaddress instead of my backoffice web address. aftward I was able to pull up my site and the backoffice login.. When I logged in, WP 2.8 was already running.

    YAY!

    Thanks,
    Laura

    I found this same error after doing a manual install.

    Simply reuploaded the ‘http.php’ file – the same one that was in the 2.8 download and that fixed it.

    Thanks @michaelh for suggesting it – never would have guessed it was that easy.

Viewing 15 replies - 1 through 15 (of 57 total)
  • The topic ‘Error when upgrading to WP2.8’ is closed to new replies.
Skip to toolbar