The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Connections Business Directory
[resolved] Error when upgrading to (10 posts)

  1. providencehouston
    Posted 3 years ago #

    I get this

    Parse error: syntax error, unexpected T_SL, expecting ')' in /home/frankwil/public_html/mobile/wp-content/plugins/connections/includes/class.settings.php on line 417

    I even tried deleting and reinstalling it. Same thing.


  2. n8tive
    Posted 3 years ago #

    same for me - just killed my site - help please

  3. If it's the plugin (and it sounds like it is) try these steps:

    1. Using FTP or whatever filemanagement tools your host has provided you with navigate to the wp-content/plugins directory. File management like that is done without using your WordPress dashboard.
    2. Once there locate and delete the connections directory. Just that one directory and nothing else.
    3. Try and re-login to your WordPress dashboard.

    See if that lets you into your installation.

  4. magweb
    Posted 3 years ago #

    And me. Had to edit my wp_option data for active_plugins to get the site back but leaving the Connections plugin disabled.

  5. magweb
    Posted 3 years ago #

    see other forum posts for fix

  6. I'm glad you got yours working. Those directions I posted above will accomplish the same thing without having to modify any mysql tables. ;)

  7. shazahm1
    Plugin Author

    Posted 3 years ago #


    Please just delete Connections and reinstall. It is safe to do and you will not lose anything.

  8. providencehouston
    Posted 3 years ago #

    @Shazahm1, I applied the fix recommended by tassos. It worked. However, I noticed you pulled the latest update and reverted to .x.x.x.4. I guess you realized this IS an issue.

  9. shazahm1
    Plugin Author

    Posted 3 years ago #

    @ providencehouston

    Yes, I pulled the update because that was quickest solution to ensure no one else is affected.

    The root issue was a merge conflict which inserted the marker text that needs to be deleted. Unfortunately, when this merge conflict occurred I didn't get an error message that I should have received. So this went undetected.

    Before re-releasing the update, I just want to double-check the code to make sure all the expected changes are in place and there are no other merge conflict markers hidden elsewhere in the code.

  10. providencehouston
    Posted 3 years ago #

    @Shazahm, no worries. I appreciate your willingness to fix the problem right away:-)

    Thats better than many other big name developers I can think of.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Connections Business Directory
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.