Support » Plugin: WooCommerce » Error when updating to wooCommerce 4.6.0

  • Resolved stelat

    (@stelat)


    Hi
    When I tried to update to Woocommerce 4.6.0 I got a critical error.
    Had to login in Recovering Mode and deactivate the plugin.
    When i try to re-activate it, I get this error:

    “Fatal error: require(): Failed opening required ‘/public_html/wp-content/plugins/woocommerce/src/Autoloader.php’ (include_path=’.:/opt/alt/php74/usr/share/pear’) in /public_html/wp-content/plugins/woocommerce/woocommerce.php on line 24”

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support wpnomad a11n

    (@wpnomad)

    Hi @stelat ,

    It seems that code from one of the installed plugins or theme on your site is causing a conflict with WooCommerce 4.6.

    Here’s what I recommend:

    1. Set the theme to default ( like Storefront)
    2. Disable all other plugins except WooCommerce.
    3. Update WooCommerce to latest version.
    4. Enable other plugins one by one until you notice an issue.

    Do let us know how that goes and if you need any further help from us.

    Thread Starter stelat

    (@stelat)

    I just deactivated all the plugins on the website.
    WooCommerce is updated to the latest version Version 4.6.0

    However, when i try to Activate just the WooCommerce plugin. The same error appears

    (I can not set theme to Storefront as WooCommerce is Deactivated at the moment and i can’t Activate it, due to to the error)

    Same thing is happening to me with 4.6.0 version: Fatal Error each time.

    Am upgrading hosting pkg to see if that makes a difference.

    After upgrading hosting, still occurred. I solved the issue by deleting the basic woocommerce plugin and doing a fresh 4.6.0 install. Then everything worked. Fortunately I didn’t lose any product data, but I have to update the woocommerce database. Everything else seems to be working…

    Plugin Support wpnomad a11n

    (@wpnomad)

    Hi @stelat ,

    I just deactivated all the plugins on the website.
    WooCommerce is updated to the latest version Version 4.6.0

    However, when i try to Activate just the WooCommerce plugin. The same error appears

    That is strange. Can you try deleting the existing WooCommerce plugin and doing a fresh install of WooCommerce like @bizdata has suggested?

    Do let us know how that goes.

    Thread Starter stelat

    (@stelat)

    I deleted and then reinstalled the woocommerce plugin and it did fix the problem.
    Could this be from the site cache? (I forgot to test this before i deleted the plugin)

    had all the same issues. Deactivated all plugins, set to WP 2020 theme and tried to update Woocommerce. Broke my site and I had to do a restore.
    Further tried to delete the Woocommerce plugin after getting back into the WordPress dashboard, reinstalled then tried to process an order, 500 error. Refresh brought the screen back up, further plugin updates caused another 500 error. Had to restore from backup.
    Second try after 3rd restore, deactivated all plugins, default theme, deleted Woo, updated plugins, reinstalled woo, tried to process an order (last time where 500 error occurred) and processed correctly.
    Back up you stuff is the lesson of the day 😉

    Plugin Support wpnomad a11n

    (@wpnomad)

    Hi @stelat ,

    Could this be from the site cache?

    That’s possible but not too likely. It’s possible that something didn’t go right during the update the first time, which is why a fresh reinstall fixed the problem.

    Thanks for chiming in @vau6hn. If you need support, then please create a new thread.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error when updating to wooCommerce 4.6.0’ is closed to new replies.