[resolved] [closed] Error when trying to logout (76 posts)

  1. Dion Hulse
    Lead Developer
    Posted 5 years ago #

    Given that a lot of people using Fatcow seem to be having the same issue, has anyone contacted their host to ask to see if the host has an idea as to whats happening?

  2. squishy79
    Posted 5 years ago #

    I did, they basically said that it is a WordPress issue and to contact WordPress.

  3. interconnect
    Posted 5 years ago #

    I didn't even bother because I knew that would happen. I don't have Fatcow though, I use IPOWER; some other people have mentioned they use IPOWER too... maybe it is a host issue. Regardless, this issue still hasn't been resolved. It'd be nice if a developer or someone could help us track down the cause, whether it be a WordPress or a host issue. I would gladly inform my host of an issue if we even had a clue as to what it was.

  4. Dion Hulse
    Lead Developer
    Posted 5 years ago #

    If someone can contact me off the support forum with a test install, or a account that I can set one up on to test with, on a server that exhibits the issue, that'd be appreciated So i can see if i can track it down.

  5. chaudt15
    Posted 5 years ago #

    I have the same exact problem, I my host is FatCow as well!!!!!!!!!!

  6. windowsforeyes
    Posted 5 years ago #

    I'm having the same problem but it is only happening on one of the two WordPress sites that I host through HostGator. The one that doesn't work is for a client, so I need to figure out how to fix it asap.

  7. Dion Hulse
    Lead Developer
    Posted 5 years ago #

    If either of you could email me directly to see if I can figure out the problem, That'd be great:

    Removed email as enough people have contacted me. If anyone else has further issues, please contact your host directly and link them to this thread.

    As a followup to this,
    I've got tickets with iPower and Fatcow support currently that is being worked through.

    There's still no news to report, however, I'll let this thread know the outcome.

  8. ufosolutions
    Posted 5 years ago #

    I have recently installed serveral WordPress test websites on my new FatCow account. I have been using another host and have built many WordPress websites and never experienced this log out error before, but now I am using FatCow I have a problem and a support tick that just keeps going. They have suggested several things to try all of which hasn't resolved it.
    It's seems to be intermittent and works fine then doesn't? I know this seems a weird error so fault finding becomes difficult. I would just like to get to the bottom of it too.
    The only thing I can think of that I am now doing differently is my installation uses the FatCow auto install function. In the past I always used FTP and then did it by myself as my previous host had no auto installation.
    Any progress in this log out error??????

  9. 123milliseconds
    Posted 5 years ago #

    2 months still no joy

    Searching on

    "Error 101 (net::ERR_CONNECTION_RESET): Unknown error."

    gives hints so yu can do own research and troubleshooting while waiting 3 weeks for host ; still waiting ...

  10. ufosolutions
    Posted 5 years ago #

    After many hours and days of support tickets I have been told,

    Unfortunately, since WordPress is a 3rd party product, we do not provide direct support for it beyond assisting with the installation. Please contact WordPress support at http://wordpress.org/support/ to get assistance with WordPress.

    But I think there isn't a problem with WordPress otherwise there would been many more unhappy people ATM. It seems to be something to do with external settings on some servers, I have given up and pray that someone else can find a solution and shere it with us................

  11. Population2
    Posted 5 years ago #

    I'm having the same problem (FF3, IE8, Win 7,XP, WordPress 3.1). My site hosted by Fatcow as well.
    I contacted their support, but no help. They said they can't replicate the issue.

    This is only happen on the WP 3.1. I have another site hosted by Fatcow (WP 3.0 ) but it works fine.

  12. ufosolutions
    Posted 5 years ago #

    It's funny how we are all having simialar log out problems but FatCow can't reproduce any fault? They have had pleanty of people telling them the same thing and they point tne finger at WP, I don't beleive that it has anything to do with WP and still have no idea how to fix it.

    Has anyone found a solution?

  13. dwdutch
    Posted 5 years ago #

    @dd32 - Dion, have you made any progress in your investigation?

  14. dwdutch
    Posted 5 years ago #

    well, i did nothing. yesterday, it did not work. Today, it does. I use fatcow for my hosting also. Perhaps they made a change.

  15. Population2
    Posted 5 years ago #

    That's weird. I'm still having that problem.
    I use Fatcow also.

  16. ufosolutions
    Posted 5 years ago #

    I have moved some WordPress sites off FatCow to another server and have no problem at all with Loging Out, I still have problems with the websites still hosted with FatCow and they don't admit any fault on their side. I am still no closer to finding and solution :(

  17. squishy79
    Posted 5 years ago #

    This was a recent chat with FatCow Support.
    Scott Morris: Hi Matt, my name is Scott. How are you today?
    Matt: Well, you?
    Scott Morris: How can I help you today?
    Scott Morris: I'm great, thank you.
    Matt: I currently have 4 WordPress sites hosted with FatCow and all 4 are having the same issue. When I log out of a site I am taken to a page that says: The connection was reset The connection to the server was reset while the page was loading. The site could be temporarily unavailable or too busy. Try again in a few moments. If you are unable to load any pages, check your computer's network connection. If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.
    Matt: I did some research on WordPress.org forums and found that I am not the only one having this issue. Most people who are experiencing this issue report that they are with FatCow.
    Scott Morris: I apologize for any inconvenience this has caused you.
    Scott Morris: Could you please provide me with the exact URL of the web page in which you are receiving the error?
    Matt: I could give you a temporary sign on to one of my sites if you would like to test it.
    Scott Morris: Yes, please,
    Matt: Did you change something? ...this issue has been happening for months...and now all of a sudden it is working normally.
    Scott Morris: I have not made any changes.
    Matt: nevermind...it's doing it again
    Matt: http://mattandelise.com/wp-login.php?action=logout&redirect_to=http%3A%2F%2Fmattandelise.com%2F&_wpnonce=1ca59d517f
    Matt: site url is: http://www.mattandelise.com
    Scott Morris: Please provide me with the login
    Matt: temporary username and pasword are:
    Matt: u: xxxxxxxxx
    Matt: p: xxxxxxxxx
    Scott Morris: I have just logged into the WordPress Dashboard and then logged out but was unable to duplicate your issue,
    Matt: It did it to me again
    Matt: http://mattandelise.com/wp-login.php?action=logout&_wpnonce=1ca59d517f
    Matt: http://wordpress.org/support/topic/error-when-trying-to-logout?replies=46
    Scott Morris: Once I logged out from the WordPress Dashboard, I was redirected to the page at http://mattandelise.com/wp-login.php?loggedout=true
    Matt: that is a link to the WordPress forum where everyone is posting about the issue.
    Matt: what browser are you using?
    Scott Morris: I'm using Firefox version 4.0/
    Matt: same here
    Matt: I have been able to duplicate the issue in IE, Firefox, Opera, Safari and Chrome
    Scott Morris: Could you please clear the browser cache and cookies and then try to access it?
    Matt: trying now...
    Scott Morris: Okay,
    Matt: nope...still doing it
    Matt: I tried it on 3 of my 4 sites
    Matt: two different 3 different browsers
    Matt: *sorry 3 different browswers
    Scott Morris: Okay.
    Scott Morris: I have tried to log in and log out from different browsers from my end and was unable to duplicate the issue,
    Scott Morris: Could you please restart your local computer and then check this?
    Matt: No, I have been working on this issue for literally months now...I reboot my computer every day.
    Scott Morris: OKay.
    Scott Morris: Your website is working file and I can log in and log out to the Dashboard without any error.
    Scott Morris: Unfortunately we do not provide support for the WordPress application beyond assistance with the initial installation through "SimpleScripts". We would recommend that you contact the WordPress support community found here:
    Scott Morris: http://wordpress.org/support/
    Matt: This is the same canned answer that everyone keeps getting from FatCow... is there not a way to escalate the issue?
    Matt: WordPress developers have also been working on the issue...which is more than we can say for FatCow.
    Matt: They are at least trying....
    Matt: I could understand if it was just me having this issue....but it's clearly not.
    Scott Morris: Unfortunately, we have no access to isolate this from from our end and this is the reason we are diverting you to WordPress support/
    Scott Morris: I can understand your concern.
    Matt: Is there not a 2nd level support there?
    Scott Morris: Yes. we have./
    Matt: Can you not escalate the issue to them?
    Scott Morris: There is no use.
    Matt: Wow...
    Scott Morris: Our specialists also do not have access to the tools to fix the issue which is related to WordPress application,
    Matt: Thanks for nothing....
    Scott Morris: I apologize for any inconvenience this has caused you.
    Matt: yep

  18. ufosolutions
    Posted 5 years ago #

    Hey Matt,

    I know how you feel, I had almost the same support ticket trail, I had some customers complain so I moved off their websites to another server and guess what not one log out error!!!!! I am not sure why they can't reproduce the fault? We all can . . . . .

  19. squishy79
    Posted 5 years ago #

    Cautiously Optimistic....

    Okay, here is what I have tried and so far it appears to be working...

    I modified my php.ini file in the following ways:

    1. Set the max script execution time to 90 seconds. ( It was 300 ).
    2. Set the php memory limit to 128m. ( It was 32m ).
    3. Verified that the session.save_path was pointed to the appropriate location. ( Mine, according to FatCow [for whatever that is worth] was correct ).
    4. Enabled (turned on) zlib.output_compression

    1. Log into your FatCow control panel and click "Scripting and Add-Ons" from the main menu.
    2. Click "CGI and Scripted Language Support".
    3. Click "PHP Scripting".
    4. Near the bottom of the page you will see an area highlighted in orange saying "Edit your php.ini file for PHP"
    5. I copied the entire text from the PHP.ini file into a blank text file so I had a handy backup.
    6. I then pasted that same text into Notepad++ which is a handy free code editor
    7. I then changed line 244 to: max_execution_time = 90
    8. I then changed line 246 to: memory_limit = 128M
    9. I then verified that line 881 was correct: session.save_path = /home/users/web/b318/moo.mysitecom/cgi-bin/tmp
    10. Finally, I changed line 126 to: zlib.output_compression = On

    ***Note - The line numbers I am referencing above are coming from Notepad++ not the PHP.ini file.

    I am going to try this for a week or so [fingers crossed]...

  20. sy.dney
    Posted 5 years ago #

    Worked like a charm. Thanks Matt.

  21. squishy79
    Posted 5 years ago #

    Update: This is still working. The only thing I have noticed is a slight conflict with the W3 Total Cache plugin. It doesn't seem to like the zlib.output_compression being enabled.

  22. ufosolutions
    Posted 5 years ago #

    Hey Matt,
    Glad the php.ini mods worked for you, my websites are all working fine now with no issues at this stage.

  23. paintscape
    Posted 5 years ago #

    Just to let you all know the edits for the PHP.ini file worked for me too. Thanks!

  24. Jesse2020
    Posted 5 years ago #

    Thanks squishy79!!! I tried each of your suggested php.ini changes individually, and the only one I needed was:

    zlib.output_compression = On

    FYI: This issue is not related just to FatCow - I use StartLogic and had the same issue. Interestingly, StartLogic also uses "SimpleScripts" to support their installs...

  25. Andrew
    Posted 5 years ago #

    Squishy79 is my savior! This was driving me absolutely insane!

  26. www.agentstaobao.com
    Posted 5 years ago #

    Thanks squishy79!!! I tried each of your suggested php.ini changes individually, and the only one I needed was:

    zlib.output_compression = On

    FYI: This issue is not related just to FatCow - I use StartLogic and had the same issue. Interestingly, StartLogic also uses "SimpleScripts" to support their installs...

  27. bonn1266
    Posted 5 years ago #

    I just want to share that my client has two sites both hosted at Ipowerweb
    and I am experiencing the same issue with the logout.

    I am about to apply the zlib.output_compression=on

    I wanted to share they use simple scripts as well.


    zlib.output_compression=on ....did the trick..

    I guess I will have to find a seo plugin that will work with this setting

  28. Milan Dinić
    Posted 5 years ago #

    Since nobody else noticed, just to point out that this issue is actually related to one provider that has different brands. FatCow, iPower, StartLogic, they are all brands of Endurance International Group.

  29. smazaz
    Posted 5 years ago #

    I just want to say a massive THANK YOU for this help squishy79

    I am using startlogic and when testing my site, I could not log out as an admin or test subscriber, it was driving me mental!

    Followed your instructions (they work even via StartLogic)

    The only one I needed to change was: zlib.output_compression = On

    Thanks again!

  30. hhusted
    Posted 5 years ago #

    Hey folks, it is not a hosting issue. I have Dot5hosting and I get the same problem. I only get it with Firefox. When I use IE I get no errors. And when I contacted Dot5hosting support, they tried to duplicate the error using Firefox with no problems. So it has to be a bug in Firefox. I read many of your comments and it seems that you are using Firefox 3.1 and newer. Perhaps there is a bug in Firefox.

    I am going to check with Firefox and see where the error may be.

Topic Closed

This topic has been closed to new replies.

About this Topic