Support » Plugin: Simple Signup Form » ERROR when submitting email address

Viewing 7 replies - 16 through 22 (of 22 total)
  • I recently installed this plugin and am having trouble with the subscription form showing up on every page of my site. When I uncheck “global signup form” it then removes the sub form from my site entirely. How can I fix this?

    Plugin Author pantherius


    Simply add the shortcode that you can find on the admin (in the form settings, at the top-right corner) to the desired page using the editor, like:

    [ssf id=1918584439]

    Thank you. I’ve added the form’s shortcode to the HTML text box on the page I want it to display to. Now, when I uncheck “global signup form” it completely disappears from my site. I’ve also unchecked “once per filled out” to ensure that it will show even after I’ve entered my email address.

    Plugin Author pantherius


    You’re welcome.

    Please add the shortcode to your WYSIWYG Editor using the Text view (source code view). You can also add it to the WordPress default text widget, if you using the PRO version.

    The code box or any other area probably doesn’t process WordPress shortcodes.

    The Send Email error is still there. Kindly advice

    Yes Under Wood I agree with you when you remove Global it just vanishes

    Plugin Author pantherius


    Hello techprem,

    You have two ways to use the plugin:

    – enable Global Signup Form, then the form will appear on all pages
    – disable Global Signup Form and add [ssp id=”formid”] on the page where you would like to use it

    The plugin using the standard wp_mail() function to send emails. It may not work properly, if your hosting provider doesn’t allow to use PHP mail() function.
    You can read more about troubleshooting this issue here:

    You can also use this plugin to test the mail function on your website:

    Best regards,

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘ERROR when submitting email address’ is closed to new replies.