Support » Fixing WordPress » Error when saving/updating | Have just uploaded from localhost.

  • Resolved davbrn



    I have my site working live on the net after uploading from MAMP yesterday but there are a couple of gremlins.

    When I upload/edit an image and hit ‘update media’ it redirects me to a 404 page on my site:


    Also I had a shareaholic plugin which worked fine on my localhost but went wrong upon upload. Some of the icons weren’t showing so I changed settings and tried to update and was redirected to the 404 page on the site with a similar URL. Upon advice of shareaholic I clean uninstalled the plugin and reinstalled but now I cannot save the settings to use the plugin as I get the same 404 redirect.

    I have tried disabling all plugins and re-enabling, checked my database when I changed all the domains in case I changed a link by accident with find and replace from localhost to my domain and have been through every file on the server looking for obvious errors.

    There may be other save settings that don’t work too but I haven’t tried everything yet.

    Just to note I can update and add new posts and pages, just updating media and certain plugins.

    Must be a link issue?

    Any help would be greatly appreciated. 6 hours and counting on this issue so far!


Viewing 2 replies - 1 through 2 (of 2 total)
  • Did you replace all the old links and file paths in the SQL from the local database before importing into the live one? If not, or if not done properly, this can cause multiple problems.

    Links and upload paths are serialized in many database records. A simple search-and-replace will make those serialized values invalid and break all references to them.

    Here is an article showing the steps I use to migrate a site from my local install to an online one:


    Thanks for your reply. I did replace all the links and paths (correctly I hope!).

    I kind of gave up with this issue as I couldn’t find a solution until last week when I started having issues updating posts. I got onto live chat with my hosting provider and explained the problems and they said it was a lack of memory on my package because of plugins (mostly Jetpack).

    They increased my memory (for free) and everything has been great now for a week.

    Thanks for your help.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Error when saving/updating | Have just uploaded from localhost.’ is closed to new replies.