Support » Plugin: Events Manager » Error When Saving New Events

  • Resolved jphogan

    (@jphogan)


    When I try to save a new event, I receive the following message:
    “Your event details are incorrect and cannot be published, please correct these errors first:

    Something went wrong saving your event to the index table. Please inform a site administrator about this.”

    I have been using this plugin for two years (consistently updated) and this is coming out of nowhere.

    I have tested removing/adding location, all day/ not all day, etc. No luck.

    I found this topic here and, per the suggestions, deactivated all other plugins, but no luck. I also switched back to the default theme. Same error.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support angelo_nwl

    (@angelo_nwl)

    are you getting any php error or using browser > error console > any javascript error?

    Thread Starter jphogan

    (@jphogan)

    Thank you for your follow up. No, there aren’t any console errors.

    Here are some more troubleshooting steps I’ve done on my local dev environment and the odd things I’ve encountered. None of these troubleshooting steps allowed me to publish an event.

    Through the dashboard, I deleted all past events and drafts. Oddly, there were still 6 events in the em_events table with an event_status of -1. I deleted those manually through the db.

    I attempted to “uninstall” the plugin through the dashboard, but that did not work.

    I deactivated the plugin and removed manually. I dropped all the em_ tables.

    Oddly, at this point, my loop was still pulling in two “event” post types. I found those in the _posts table and deleted those manually.

    I redownloaded the latest version of EM from the WP repository and installed. It registered my post type, but I could not create any new events.

    I looked at my db and noticed there were no em_ tables created after reinstalling the plugin.

    I attempted to make a change on the EM Settings tab to hopefully store some tables, but I received this error: “Colors must be in a valid hex format, such as #FF00EE. This setting was not changed.” This would not allow me to save in Settings changes, no would it create any em_ tables.

    Is there somewhere I can download previous versions of the plugin?

    I am happy to provide a staging environment if this is something you’re interested in troubleshooting.

    These same table errors are happening on my live site and my local development site.

    Thank you

    Plugin Support caimin_nwl

    (@caimin_nwl)

    It sounds like there’s something not right with the database.

    Was this a clean install or were you upgrading from an earlier version?

    Thread Starter jphogan

    (@jphogan)

    This was initially a clean install. It has worked fine for a year or so with regular plugin updates. This seemingly came out of nowhere.

    It’s odd that I can’t even reinstall the plugin because it can’t seem to create the necessary tables anymore

    Plugin Support caimin_nwl

    (@caimin_nwl)

    Is there any chance that the database user associated with WordPress no longer has permissions to create database tables?

    It might be worth testing by installing another plugin that creates its own database tables to see if it’s able to create a table.

    I identified the problem as being the Yoast SEO 6.2 plugin – when I deactivated this, everything worked.

    Plugin Support angelo_nwl

    (@angelo_nwl)

    thanks for the update however it seems to be working fine on our test server; it might be with the combination of your activated plugin or theme?

    Thread Starter jphogan

    (@jphogan)

    Update: decided to try this again with the latest 5.9.2 update and now I can save events just fine. Not sure what changed with this version, but it fixed the issue!

    Thread Starter jphogan

    (@jphogan)

    marking as resolved

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error When Saving New Events’ is closed to new replies.