Support » Plugin: EWWW Image Optimizer » Error when resuming a stalled bulk optimization

  • Resolved SeanRNicholson


    I am getting an error with the bulk optimizer on version 1.3.7

    1) Start the bulk optimize process
    2) After about 70 seconds, the process stops
    3) I click the resume button
    4) The error below presents itself

    Warning: Invalid argument supplied for foreach() in /home/…/ewww-image-optimizer/bulk.php on line 52

    Debug information is as follows:

    jpegtran: OK version: Independent JPEG Group’s JPEGTRAN, version 9 13-Jan-2013
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.68
    GD: OK   Imagemagick ‘convert’: OK
    safe mode: Off  exec(): OK  shell_exec(): OK  finfo: MISSING  getimagesize(): OK  mime_content_type(): OK
    Operating System: Linux

    Debug Info

    jpegtran path: [Myprivateinfo]/wp-content/ewww/jpegtran
    optipng path: [Myprivateinfo]/wp-content/ewww/optipng
    gifsicle path: [Myprivateinfo]/wp-content/ewww/gifsicle
    pngout path:
    disabled functions: dl
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author nosilver4u


    can you look to see if there is a file named ewww.tmp in the wp-content/uploads/ folder? If you’re using a different uploads folder, that would be useful information also.

    I do use uploads, but I don’t see that file in my folder.


    Plugin Author nosilver4u


    Well, that is the problem, but I wonder why it is happening.

    If you start from the beginning (click the ‘Run all my images through…’ button), can you watch the uploads folder (make sure to refresh it while the bulk process is running) and see if the ewww.tmp file ever gets created?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error when resuming a stalled bulk optimization’ is closed to new replies.