Support » Plugin: Google Doc Embedder » Error when reactivating

  • Resolved joshuaswiss


    I had a plug-in error and deactivated all my plugins. When reactivating GDE, this message appeared:

    Fatal error: Cannot redeclare jquery_init() (previously declared in /home/content/18/7543918/html/wp-content/themes/CleanSlide/functions.php:13) in /home/content/18/7543918/html/wp-admin/functions.php on line 18

    I tried deleting and reinstalling, but kept getting the same error. Anyone know how to fix it?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author k3davis


    Hi Joshua,

    Neither of those errors are specific to GDE, but it looks like the issue is with your theme (or possibly a conflict between your theme and something else). Perhaps the theme is loading its own copy of jquery instead of using the version provided with WordPress? And perhaps the version in use is also not the same between the two?

    I’m only guessing on this, but it’s been known to happen (especially if you just updated to WordPress 3.5, which has an upgraded jQuery library). I would reach out to the theme developer, or momentarily switch themes just to confirm if it’s the source of the problem. Possibly you’ll be able to activate your plugins with that other theme installed and then switch back to the theme you want, and not suffer incompatibilities. But again, that’s just a theory on my part.

    Hope this helps,


    Hi Kevin:

    I gave your suggestion a shot and switched themes, trying to reactivate with a different theme. Unfortunately, a new error message came up:

    Warning: require_once(includes/shortcodes.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/18/7543918/html/wp-admin/functions.php on line 9

    From previous head-banging-on-walls sessions I’ve found that this error usually means a plugin problem. Could there be a conflicting plugin?

    Plugin Author k3davis


    Yes, it’s possible.

    If you’re comfortable doing so, please change the first line of code in gviewer.php under the GPL statement, which reads:



    require_once( plugin_dir_path( __FILE__ ) . '/functions.php' );

    The way some plugins and themes are coded breaks relative paths in other plugins. This makes the path absolute in GDE and this patch will be included for good measure in the next release.

    Let me know how you fare with it…

    Worked like a charm. You sir are a scholar and a gentleman. Cheers!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error when reactivating’ is closed to new replies.