WordPress.org

Forums

IP Blacklist Cloud
[resolved] Error when posting comments (7 posts)

  1. spamb0t
    Member
    Posted 2 years ago #

    I noticed today that every time someone posts a comment they end up on a white page with some error messages that say;

    Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /customers/0/7/1/kulturskurkarna.se/httpd.www/players/wp-content/plugins/ip-blacklist-cloud/ip_blacklist_cloud.php on line 1765 Warning: Cannot modify header information - headers already sent by (output started at /customers/0/7/1/kulturskurkarna.se/httpd.www/players/wp-content/plugins/ip-blacklist-cloud/ip_blacklist_cloud.php:1765) in /customers/0/7/1/kulturskurkarna.se/httpd.www/players/wp-includes/pluggable.php on line 876

    The comment is still being posted, but I don't really want it looking like that. Anyone know what the problem is? I really want to keep using IP Blacklist to block some crawler traffic and to keep better track of real people visiting the site. Spam is not an issue (yet) because of captcha protection however. Any solution?

    Here's the URL for the site, it's currently using the theme Noteworthy.
    http://kulturskurkarna.se/players

    http://wordpress.org/extend/plugins/ip-blacklist-cloud/

  2. ad33lx
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    The problem is with PHP configuration.

    Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir

    Please read this: http://stackoverflow.com/questions/6918623/curlopt-followlocation-cannot-be-activated

    I hope it helped you.

    Otherwise, Please let me know if you dont want to turn off the Safe Mode "Off" or can not make changes to open_basedir.

    I am working on V1.7 I will make changes and look for another alternative :)

    Please do respond.
    Thanks,
    Adeel

  3. ad33lx
    Member
    Plugin Author

    Posted 2 years ago #

    Please do reply about last message I will add a fix in V1.7 meanwhile you can cope up with that error by turning an option to "No" in IP Blacklist settings, that is "Auto post comments to Cloud for spam reports:"

    In this will, it will not try to contact plugin spam report file. :)

  4. spamb0t
    Member
    Posted 2 years ago #

    Well, it's not my server, but a friends but from what i've read neither turning safe mode off nor making changes to open_basedir is recommended.

    Is there any serious issues with setting CURLOPT_FOLLOWLOCATION to false? That at least solved the issue, but I'm not exactly sure what the other problems may arise if I do that.

  5. spamb0t
    Member
    Posted 2 years ago #

    But I turned the option off and it solved the problem, like you said. Thanks!

  6. ad33lx
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Good to hear that at least problem is solved by turning the option off :)

    I will remove curl function and add other function to interact with the spam report file in Version 1.7 :)

    I will contact you again to test same problem with version 1.7 :)

    I am setting this topic as Solved as your said your problem is solved now.

    Regards,
    Adeel

  7. ad33lx
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Version 1.7 has been released please update and check if the problem is still there by turning on that option "Auto post comments to Cloud for spam reports:"

    Please update me :)

    Thanks,
    Adeel

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.