Support » Plugin: ShortPixel Image Optimizer » Error when optimizing images – invalid image format.

  • Resolved asen85

    (@asen85)


    I receive error when optimizing images with the plugin (tried with several different images)

    There was an error and your request was not processed. (skyline-4582510.jpg: Invalid image format)

    Recently I made some changes and put EZOIC ads on my website. To do that I switched the DNS servers from Siteground to EZOIC.

    Please help!

    Many thanks!

    Asen

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author ShortPixel

    (@shortpixel)

    Hey @asen85 – could you please check this doc and see if it helps you figuring out the cause of the problem noted by you?

    https://shortpixel.helpscoutdocs.com/article/120-invalid-image-or-unsupported-image-format-error

    Regards,
    Alex

    asen85

    (@asen85)

    Hi Alex,

    I saw that document but still I can’t figure out the root cause.
    I eliminated the possible reasons and I’m left with

    • A firewall that prevents our servers to access your images. Please whitelist our IPs.
    • Restrictive rules in the .htaccess file. A quick way to check whether .htaccess is the reason for this issue is to temporary change the file’s name to -for example- .htaccess_tmp and then try again to see if the plugin can optimize a newly added image.

      But I’m not sure how to check this. Can you help me identify the root cause?

      Many thanks!

    asen85

    (@asen85)

    Any updates on this one?

    Many thanks in advance!

    Plugin Support Gerard Blanco

    (@sixaxis)

    Hey @asen85,

    To check that, you need to access your files via FTP. In the root folder, you will find an .htaccess file. Please rename it to .htaccess_tmp and then try again to optimize. After this optimizing attempt, rename it back to .htaccess.

    If that fixes the issue, you need to figure out why your .htaccess is preventing the optimization.

    If that doesn’t fix the issue, can you please send us the URL of the problematic image so we can check it from our side?

    Thank you,

    asen85

    (@asen85)

    Hi Gerard,

    Thanks for your reply.
    I tried renaming the.htaccess but it is the same issue. In fact I noticed that it happens sporadically. in 1-2 out of 10 cases it works but most of the time it doesn’t.
    It’s been working for almost a year.
    I try with any image from unsplash.com

    Please tell me how to proceed further.

    Thank you!

    Plugin Support Gerard Blanco

    (@sixaxis)

    Hi @asen85,

    Would it be possible to send us the exact URL of any image you see currently not working?

    Thank you,

    asen85

    (@asen85)

    asen85

    (@asen85)

    Hey guys,

    Any updates on this one?

    Plugin Support Gerard Blanco

    (@sixaxis)

    Good morning @asen85,

    Sorry, I didn’t explain myself properly. What I meant is the URL from your website. Something like http://www.yoursite.com/blabla/yourimage.jpg.

    If you prefer to not write here such URL, you can send it to us via this contact form, making sure you mention this ticket.

    Best,

    asen85

    (@asen85)

    Good morning Gerard,

    Here it is:

    https://gearuphiking.com/wp-content/uploads/2019/11/peter-thomas-iRB4Xg52Lj8-unsplash.jpg

    Is this that you want?

    Asen

    Plugin Support Gerard Blanco

    (@sixaxis)

    Hi Asen,

    Yes, exactly, thanks for that.

    It looks like there is an issue opening the URL, and that’s why ShortPixel is complaining.

    Once you fix this (you should probably talk to your hosting provider), then ShortPixel will be able to optimize your images.

    Let me know if you have any questions, please.

    Have a good day!

    asen85

    (@asen85)

    Hi Gerard,

    Thanks for the explanation.

    Can you please point me towards what exactly should I explain to the hosting provider? What is the obstacle exactly?

    Thank you!

    Asen

    Plugin Support Gerard Blanco

    (@sixaxis)

    Good morning Asen,

    As of now, I see that the image can be opened correctly. I can’t be sure 100% because I didn’t check the size before, but I believe that now the image has been optimized by ShortPixel, because it loads much faster than before.

    My guess is that some images are very heavy, and your hosting provider for some reason cuts the connection too soon.

    So, first try to reproduce again the issue with another heavy image and then, just explain your hosting what’s happening, that the image can’t be loaded properly. You can show them the URLs I told you in my previous message. They should be able to help you.

    Cheers!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error when optimizing images – invalid image format.’ is closed to new replies.