Support » Plugin: WordPress Social Login » Error when logging with Fb

Viewing 8 replies - 16 through 23 (of 23 total)
  • I added the author’s solution above to my functions.php file and it worked like a charm. We’re back in business where people can log in using their Facebook credentials again.

    wp-content > themes > functions.php is where you find that file to add it.

    You can also add it to the /wp-content/plugins/wordpress-social-login/wp-social-login.php and it would work there too.

    Either way works.

    Thanks for supplying the adjustment to the code. Question for the plugin author: Any possibility this can be added an upcoming release?

    Thanks,
    Will

    Hey Will (@wrhull);
    tried as you suggested and moved the suggested code bit to (the end of) /wp-content/plugins/wordpress-social-login/wp-social-login.php
    Sadly, it still doesn’t work for me.

    The plugin seems to connect properly to facebook (which I derive from it displaying the proper user profile pic + user_name + user eMail) – but when I select the option to create a new user for that profile (instead of connecting to an already existing one in the wp-user-base) I get failure to create user. :/ https://snag.gy/H7tKC6.jpg
    [Tried with more than one browser, too.]

    Where would I go if creation of user fails?

    rodnulyah

    (@rodnulyah)

    Hi @miled!

    When you log in through Yandex, Google is an endless redirect and nothing happens.

    When authorizing via crunchyroll writes “is incorrect parameter client_id.”

    When logging in via Twitter, he writes: “Insecure login blocked: unable to get an access token or login to this application from an unprotected page. Try reloading the page using the https: / / prefix-Although the url is in https

    All url redirection specify as written in the plugin.
    Need your help!

    • This reply was modified 6 months ago by  rodnulyah.
    • This reply was modified 6 months ago by  rodnulyah.
    • This reply was modified 6 months ago by  rodnulyah.
    • This reply was modified 6 months ago by  rodnulyah.

    I found out the solution provided here will solve the problem:
    https://github.com/miled/wordpress-social-login/issues/263

    All you need to do is modify user_url column in wp_users table from varchar 100 to 255.

    another weird but workable solution turned out to be disabling editability of user-eMail and user-name on creation of new users. Don’t see why it should make a difference but a difference make it does.
    *shrug*
    either way,
    solved.

    askmediy

    (@askmediy)

    Just like Optimiza said. Had to do everything he said. Works well for me. Thank you

    Optimiza (@malditoweekend). Thank you. It worked perfectly

    pooltech

    (@pooltech)

    This works for me but….

    On redirect I get the following message:

    ops! We ran into an issue.
    Unspecified error.

    ΞΎ Facebook Graph returned an error: Error validating client secret.

    Okay I fixed this.
    The problem was my App Secret.

    Thx

    • This reply was modified 1 month ago by  pooltech.
    • This reply was modified 1 month ago by  pooltech.
Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.