Support » Plugin: PDF Embedder » error when loading a pdf

  • Resolved liberalcastilla

    (@liberalcastilla)


    Hello good day.
    I get this error when loading a pdf:
    Setting up fake worker failed: “Cannot read property ‘WorkerMessageHandler’ of undefined”.
    Do you know how I can fix it?
    Thank you.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter liberalcastilla

    (@liberalcastilla)

    By the way, I use litespeed cache

    Plugin Support PDFG Support

    (@wppdfsupport)

    Hi @liberalcastilla,

    The Fake Worker error is due to a conflict with caching tools and the PDF Embedder scripts.

    • Make sure that you are using the most up to date version of the plugin.
    • While you do not need to exclude the PDF Embedder scripts from most caching tools, you do still need to make one settings adjustment in the caching plugin to disable inline or aggregation of JS files. Please see: https://wp-pdf.com/kb/setting-up-fake-worker-failed-error-message/. Your plugin settings may differ and it may be necessary to reach out to the caching plugin support if you can not find this setting.
    • Once the plugin has been updated, flush the cache to remove the old cached scripts. It may also be necessary to manually delete the minified script.
    • Finally, clear your browser cache and reload the page.
    Thread Starter liberalcastilla

    (@liberalcastilla)

    Thanks. Solved.

    I’m facing the same issue on https://vbsdebrongooik.be/menu-middagmaal/.

    I’ve checked the settings of the W3 Total Cache (v2.1.2) plugin and the “Remove query strings from static resources” option is deactivated.

    Purging all caches does not solve the problem.

    • This reply was modified 1 year, 2 months ago by stlecho.
    Plugin Support PDFG Support

    (@wppdfsupport)

    Hi @stlecho,

    You may also need to explicitly exclude the PDF Embedder scripts from the W3 Total Cache to prevent them from being compiled as well as remove the query strings. https://wp-pdf.com/kb/setting-up-fake-worker-failed-error-message/

    It seems that in the free version of W3 Total Cache, I do not have this option: “W3 Total Cache > Browser Cache > Remove Query Strings From Static Resources”. I can only enable or disable the Browser Cache.

    Plugin Support PDFG Support

    (@wppdfsupport)

    Hi @stlecho,

    I have the free version of W3 Total Cache installed on a text environment—version 2.1.8. Under the Browser Cache » General settings, the Remove Query Strings from Static Resources is the 9th checkbox on that section.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘error when loading a pdf’ is closed to new replies.