Support » Plugin: Content Control - User Access Restriction Plugin » Error when loading a page with [content-control]

  • wmtroop325

    (@wmtroop325)


    Getting this warning when loading a page with [content-control] shortcode. This is on WordPress 5.0.1. I understand that the plugin is supported up to 4.9.9. However, I was wondering if there is any workaround, or if there is any fix underway.


    Warning: Invalid argument supplied for foreach() in /home3/troopth8/public_html/wp-content/plugins/content-control/classes/Shortcodes.php on line 69

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • deralict

    (@deralict)

    I’ve got this exact same error. I have the same plugin working fine on a site running WordPress 5.1.1, so that’s not the problem. The other site is not running WooCommerce which my site that has this problem does, so perhaps the plugin is not compatible with WooCommerce.

    Also, the [content_control][/content_control] shortcode works fine, but the [content_control logged_out][/content_control] shortcode is the one that produces the error.

    Plugin Author danieliser

    (@danieliser)

    @wmtroop325 Sorry for the delay, didn’t get an email for this ticket for some reason.

    @deralict – The extra info is useful. Let me see if I can duplicate it today and will get a patch out as well as bump the WP supported version to 5.2.

    Plugin Author danieliser

    (@danieliser)

    @deralict – Is the error message the exact same?

    Yes, it looks like

    Warning: Invalid argument supplied for foreach() in /wp-content/plugins/content-control/classes/Shortcodes.php on line 69

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.