Support » Plugin: WP Encryption - One Click single / wildcard Free SSL certificate & force HTTPS » Error when installing SSL for current domain

  • Resolved maicha


    I was told to open a ticket because I had an error when installing. This is the response log:
    ERROR: CREATE_ORDER:RuntimeException: Error creating new order :: Cannot issue for “”: The ACME server can not issue a certificate for an IP address (and 1 more problems. Refer to sub-problems for more information.) in /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/lib/LEConnector.php:188
    Stack trace:
    #0 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/lib/LEConnector.php(227): LEClient\LEConnector->request(‘POST’, ‘https://acme-v0…’, ‘{“protected”:”e…’)
    #1 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/lib/LEOrder.php(169): LEClient\LEConnector->post(‘https://acme-v0…’, ‘{“protected”:”e…’)
    #2 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/lib/LEOrder.php(147): LEClient\LEOrder->createOrder(Array, ”, ”)
    #3 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/lib/LEClient.php(172): LEClient\LEOrder->__construct(Object(LEClient\LEConnector), 1, Array, ‘’, Array, ‘rsa-4096’, ”, ”)
    #4 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/classes/le-core.php(108): LEClient\LEClient->getOrCreateOrder(‘’, Array)
    #5 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/classes/le-core.php(66): WPLE_Core->wple_generate_order()
    #6 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/classes/le-core.php(52): WPLE_Core->wple_generate_verify_ssl()
    #7 /var/www/wordpress/wp-content/plugins/wp-letsencrypt-ssl/admin/le_admin.php(263): WPLE_Core->__construct(Array)
    #8 /var/www/wordpress/wp-includes/class-wp-hook.php(288): WPLE_Admin->wple_save_email_generate_certs(”)
    #9 /var/www/wordpress/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array)
    #10 /var/www/wordpress/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #11 /var/www/wordpress/wp-admin/admin.php(170): do_action(‘admin_init’)
    #12 {main}

    • This topic was modified 3 months, 3 weeks ago by maicha.
Viewing 1 replies (of 1 total)
  • Plugin Author Vijay Prakash



    As the error states – You cannot install SSL certificate on an IP address i.e., the WordPress URL and Site URL in your Settings -> General should be domain name like and not IP address.

    Quick solution would be purchase a domain name, add a new ‘A’ record in your domain DNS settings(can be found in cPanel) with domain name( and value(IP address). This points your domain name to IP address of your site and you can use this domain name in Settings -> General of your WordPress site.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.