Support » Installing WordPress » Error When Installing 2.8.5 Update

  • Resolved zechmann

    (@zechmann)


    I get the error: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2354671 bytes) in “…” /public_html/wordpress/wp-includes/http.php on line 1331

    I tried searching google for a common problem and one forum said it could be too many plugins but that was for Joomla, and I don’t have that many.

    Anyone know what this could be? I think I might have changed permissions on a folder (i believe the wordpress folder) a while back… could that be it?

Viewing 11 replies - 1 through 11 (of 11 total)
  • – Did you do the auto-install? Have you tried to FTP upload the WP files yourself? The FTP upload or upload via cpanel File Manager works pretty well.
    – Try to deactivate plugins and change to default theme and see if it has errors
    P.S. before any upgrading, remember to backup database and server files first

    I did the autoinstall and got the same error as zechmann (exactly the same error). Stupidly didn’t backup anything first. duhhhhhhhhh. Now the ability to edit any plugins has been lost (results in a similar error)

    I’ll give your methods a go mercime.

    Good news!

    Deactivating all plugins and changing to the default theme as mercime suggested fixes it perfectly for the autoinstall.

    Thanks!

    i tried your advice, but looks not good, still my site http://www.apnimarzi.com is on old version. anyone else who tried it.

    I got the same error. I never had this problem before….what’s going on
    ?

    try adding this line to your wp-config.php

    define('WP_MEMORY_LIMIT', '64M');

    Increase the amount of memory a PHP script may consume. Note: If using a shared hosting service, you may need to ask your host to increase the limit.

    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define(‘WP_MEMORY_LIMIT’, ’64MB’);)

    I got the same error too, but once I deactivated my plugins, I had no trouble upgrading after that. No need to change themes. I have a very complicated theme (ATAHUALPA) with multiple customizations (including lots of header images) and leaving it activated during the upgrade didn’t cause me any trouble. After the upgrade, I just reactivated all my plugins and everything seems to be running smoothly now.

    Deactivated all the plugins then install worked fine 🙂
    No need to change themes like Noetical said.

    Thanks for all the useful suggestions. I think I’ll still wait a day or two before I upgrade, just to be safe. I’m starting to get a few readers and I don’t want to run the risk of messing things up at the moment. I must be getting conservative in my old age.

    I deactivated ALL plugins and the upgrade was smooth!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error When Installing 2.8.5 Update’ is closed to new replies.