WordPress.org

Forums

[resolved] Error when exporting an sql from mysql "no tables found in database" (14 posts)

  1. Stuart Richards
    Member
    Posted 3 years ago #

    Right, to start with, I am using MAMP on Mac and my localhost:8888 root directory is under users/me/sites/wordpress.

    I have created a fresh, clean install on my remote server of wordpress and successfully built a site on my local server that I need to upload onto the remote server.

    The issue I am having is I am following the steps as laid out in this this video (link: http://www.youtube.com/watch?v=cM9Z8aQTCvQ). However, when I get to the part where I have to export a sql of my local database (3:12 into the video) via phpmyadmin, I select my database (in this case called WordPress_Scope), it says WordPress_Scope (11) in the database drop down but then when opening it, I get the message No tables found in database. All other databases have files within the dropdown like Information_schema, performance_schema and mysql, but on this one database, it says there are no tables.

    Whats more puzzling is when I go to the folder Applications/MAMP/db/mysql/Wordpress_Scope/ - All the data files are all there! this is the same root location as the rest of the databases that are being found.

    I read somewhere that this may be due to a change in permissions or whatever from mysql.mysql to root.root but this means nothing to me without a clear explanation as to how to fix it!

    Any help would be much appreciated. Thought it would be easier to work remotely and upload when its all done - but this is appearing to be the biggest headache EVER!

  2. Stuart Richards
    Member
    Posted 3 years ago #

    Heres a screenshot of what i mean when it says there are 11 files in the db yet no tables are coming up:

    http://cl.ly/1p3G0M2s2q1I2F2P1n0a

  3. bobcatou
    Member
    Posted 3 years ago #

    I got your email and understand your frustration. I'm sorry to say that this is one area I don't have a lot of experience in. I know enough to optimize, empty and delete tables and I haven't done much more than that.

    From a glance it sure doesn't look like you have anything in that database. What I would do is go into your wp-config.php file and make sure your WP installation is linked to this database. After I might even try to add a plugin like WP-Optimize to your WP installation and see what it calls the database. It will show the tables in that plugin as well.

    I'm sorry I can't be much more help. If you get if figured out, please post the solution. I wouldn't be curious to hear what happened.

    I'm sure someone else here will respond. This is a good area for solutions.

    Good Luck
    Bryan

  4. Stuart Richards
    Member
    Posted 3 years ago #

    Thanks Bryan, I have been getting more and more frustrated with this as it says there are no tables but they clearly are all there in the db folder!!

    Ill take a look into the wp-config.php and see whats going on - as you say, it could just be directing incorrectly - odd as my localhost:8888 site is still working perfectly!

  5. bobcatou
    Member
    Posted 3 years ago #

    I have a little thing that is the opposite of your issue on my host server. If I look at my database list via Cpanel, it shows one of my sites db as being empty. If I go into MyPHP or look in the WP-Optimize plugin, it shows all my tables and data.

    Right now I am not worrying about it. I have bigger fish to fry.

  6. Stuart Richards
    Member
    Posted 3 years ago #

    Well according to my wp-config, I have this:

    define('DB_NAME', 'wordpress_scope');

    /** MySQL database username */
    define('DB_USER', 'root');

    /** MySQL database password */
    define('DB_PASSWORD', 'root');

    /** MySQL hostname */
    define('DB_HOST', 'localhost:8888');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    All seems in order, I then installed wp-optimizer as you said. Found all the tables and optimised them (like so http://cl.ly/1p0Y3L0W262w3J2t3D1W) and go to phpmyadmin again...nothin!

    All I want to do is delete my database from the remote host as its just a basic install of wp and replace that with the sql export from my local host - ba da bing!

    Goo luck with your fish ;)

  7. bobcatou
    Member
    Posted 3 years ago #

    Don't know what to tell ya. Let me know of any progress.

  8. Stuart Richards
    Member
    Posted 3 years ago #

    does this make any more sense to my problem? looks like its the perfect solution to my problem - although I have no idea what they mean:

    http://www.geckoandfly.com/7481/solution-for-no-tables-found-in-database-mysql-error-in-phpmyadmin/

    I have no idea what they mean by root access and putty? and what is chown -R mysql.mysql /var/lib/mysql/*? I'm guessing its something I have to copy n paste into somewhere but I'm not sure where!

    This is all I need to ge the going I think... any advice at all?

  9. bobcatou
    Member
    Posted 3 years ago #

    Hmmm....This does look like a solution to your issue but I don't know enough to help you implement it. Sorry

  10. Stuart Richards
    Member
    Posted 3 years ago #

    RESOLVED!

    Unfortunatly still have no idea whatsoever why on earth it wasn't showing up in myphpadmin but the way around it was to install a plugin on wordpress called Lime Export. This exports the tables into an sql format for importing onto the live server. Not an immediate fix but away around the issue to get the site live. Now its live without any probelms!

  11. bobcatou
    Member
    Posted 3 years ago #

    Glad you got it worked out for sure. Sometimes I guess you can't question and just be happy it is working

  12. sungoshine
    Member
    Posted 3 years ago #

    Hi Stuart,

    I'm running into the very same problem. I was following the youtube-tutorial as well.

    As I renamed the URL in my WordPress settings on localhost I'm running into another problem. I cannot login to my localhost anymore as it redirects to the new URL I entered.

    So I would like to install and run the Lime Export plugin just like you did, but don't know how to access the site on localhost. I probably have to edit some .php file but don't know which one.

    Hope you can be of help, would be much appreciated as this is driving me crazy.

    Thanks in advance.

  13. sungoshine
    Member
    Posted 3 years ago #

    After nearly going mad, I found a way to get into my localhost WP settings again
    http://codex.wordpress.org/Changing_The_Site_URL

    I followed the edit wp-config.php file by adding these lines at the top:
    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    Changed them back into http://localhost:8888

    I was able to login to my local hosted site. Now I can export the database from the WordPress dashboard instead of phpMyAdmin. Which still shows 0 tables.

  14. playboxdesign
    Member
    Posted 2 years ago #

    > Stuart Richards

    Just wanted to say a massive thanks for 'Lime Export'

    Brilliant

Topic Closed

This topic has been closed to new replies.

About this Topic