WordPress.org

Forums

Sliding Youtube Gallery
[resolved] Error when embedding (10 posts)

  1. mosaicrob
    Member
    Posted 2 years ago #

    Hi there everyone,

    Just installed this plugin. Backend looks really good. But embedding got me this error:

    "Warning: Cannot modify header information - headers already sent by (output started at /home/content/33/10225733/html/wp-content/themes/360/header.php:2) in /home/content/33/10225733/html/wp-content/plugins/sliding-youtube-gallery/engine/SygPlugin.php on line 72"

    Any help? The website is whowearemusic.com

    Thank you!

    http://wordpress.org/extend/plugins/sliding-youtube-gallery/

  2. webEng
    Member
    Plugin Author

    Posted 2 years ago #

    Hi mosaicrob,
    could you post the link where you report this problem please?

    ps. Error apart, maybe you have to set your production website to do not display warning messages.

    Let me know.

    Thank you, Luca

  3. paulh88
    Member
    Posted 2 years ago #

    I am also getting the same problem. A test post example can be found here:

    http://www.syncrenicity.com/2013/02/02/test-post/

  4. paulh88
    Member
    Posted 2 years ago #

    I just noticed that the page link I put in the previous post http://www.syncrenicity.com/2013/02/02/test-post/ does not produce the error for site visitors that are NOT LOGGED IN.

    When I log in the Error message is displayed. You said

    Error apart, maybe you have to set your production website to do not display warning messages.

    The plugin works fine so my question is, How do you turn off Error messages so that they don't display to logged in users ? And if you do that, does it compromise the stability of the site?

  5. LakeErieLive
    Member
    Posted 2 years ago #

    I have the same issue. Recently got WP 3.51 – not sure if that's the problem or not – but when I load a page that has the SYG on it – I get this message and an empty SYG gallery
    “Warning: Cannot modify header information – headers already sent by (output started at /home/content/12/6962712/html/wp-content/themes/atahualpa/header.php:2) in /home/content/12/6962712/html/wp-content/plugins/sliding-youtube-gallery/engine/SygPlugin.php on line 72″
    Is there something I can do to fix this so my gallery shows up and the error goes away?
    Also, the 'Warning' message is not there when you are not logged in as well, but the videos in the gallery still do not load.

  6. webEng
    Member
    Plugin Author

    Posted 2 years ago #

    @LakeErieLive Hi, thanks for your request. The problem seems to occour, when you are logged into the wordpress admin panel. Try this: log out, clean the cache and see if happens again without logging. If not, I think isn't going to be a real problem for your users. In other words, this isn't a real problem (I should resolve it anyway)...
    I suggest also to disable warnings on production environment in order to avoid warning message (that's not errors) to be displayed. In ten days I will release the definitive 1.4.0 version that will fix this problem. Stay tuned and let me knows if you have other questions.

    Cheers, Luca

  7. paulh88
    Member
    Posted 2 years ago #

    Hi Luca -

    Just upgraded to version 1.40 but still getting the following:

    Warning: Cannot modify header information - headers already sent by (output started at /home/syncman/public_html/wp-content/themes/buddybase/header.php:3) in /home/syncman/public_html/wp-content/plugins/sliding-youtube-gallery/engine/SygPlugin.php on line 71

    Previously this Warning displayed within the post. Now it displays at the top (head) of the page just below the Buddypress admin bar.

    Any ideas ?

    Thx

    Paul

  8. webEng
    Member
    Plugin Author

    Posted 2 years ago #

    @paulh88 hi there, as said in the previous post, the problem is present for the logged user when php warning is enabled. Sorry if I didn't fix yet but, I was very busy to release a patch to become compliant within the wordpress guidelines. I promise to release a patch in few days.

    Please be patient :)

    Luca

  9. paulh88
    Member
    Posted 2 years ago #

    @webEng hi -
    No need for you to apologise - the plugin looks very good and will be very useful to me and no doubt many others. I'm just keen to make use of it!

    I promise to be patient ;-)

    Paul

  10. webEng
    Member
    Plugin Author

    Posted 2 years ago #

    @paulh88 Hi there, thank you. I have just release a new version. Now should work. Please, send me a feedback, I ask you to rate the plugin if you didn't rate before.

    Thank you, Luca

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Sliding Youtube Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic