Support » Plugin: Gutenberg Blocks and Template Library by Otter » Error when editing button groups

  • Resolved serevinus

    (@serevinus)


    Hi,

    Just trying out all the different blocks to see which ones might be useful, and on one of the blocks I think I might use it is throwing an error which is preventing me from using it…

    When editing a button group, whenever I change a numeric value (ie. changing the number of buttons), I get an error saying “This block has encountered an error and cannot be previewed”. Additionally, in the JavaScript console I am seeing the following error “Permission denied to access property “nextElementSibling””

    Using the latest version of the plugin, the Neve theme, wordpress and all other plugins, as well as the latest version of Firefox.

    So far I have not noticed any issues with any other blocks (though I havent tried them all yet), just this one…

    Hope you can fix this.

    Thanks,
    Jim

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Hardeep Asrani

    (@hardeepasrani)

    Hey @serevinus,

    Thank you for reporting this issue. Can you give us a screenshot of the error? We will take a look at this today and get back to you.

    Thank you again! πŸ™‚

    Thread Starter serevinus

    (@serevinus)

    Hi Hardeep,

    I can’t seem to be able to upload images here so I have shared it here: https://unsee.cc/3e25181e/

    Thanks,
    Jim

    Plugin Author Hardeep Asrani

    (@hardeepasrani)

    @serevinus I tried to reproduce this issue and wasn’t able to do it. Can you please make a video so we could see exactly when this is happening? Thank you so much and sorry for the trouble.

    Thread Starter serevinus

    (@serevinus)

    Hi Hardeep,

    Please see the screen recording here: https://www.screencast.com/t/NZUzXNd0

    I have blocked out certain items, but you should be able to see everything you need.

    Thanks,
    Jim

    Plugin Author Hardeep Asrani

    (@hardeepasrani)

    @serevinus We tried and it worked for us.

    Can you use this website to create a quick test site and see if you’re able to reproduce it? https://jurassic.ninja/create/

    Apart from that, can you tell us few things:

    1. Which version of WordPress are you currently using?

    2. Can you give us the list of all the plugins that you’re using on your website?

    Thank you. πŸ™‚

    Thread Starter serevinus

    (@serevinus)

    Hi @hardeepasrani,

    I have just tested on jurassic.ninja as requested and it appears that the plugin that is breaking this block is ThirstyAffiliates. the block breaks when it’s enabled, and works correctly if it’s disabled. Unfortunately this isnt a plugin that can be removed from the site, so I am hoping that its a simple conflict that can be resolved.

    My version of WordPress is 5.2.1–en_GB, using the latest version of the Neve theme.

    Installed pluggins are as follows, all the latest versions
    Amp
    Contact Form 7
    Democracy Poll
    FileBird Lite
    Glue for Yoast SEO & AMP
    Google Analytics for WordPress by MonsterInsights
    Gutenberg Blocks and Template Library by Otter
    Jetpack by WordPress.com
    Mailchimp for WordPress (currently disabled)
    Meta Tag Manager
    Redirection
    Smart Slider 3
    ThirstyAffiliates
    UpdraftPlus – Backup/Restore
    W3 Total Cache
    Wordfence Security
    Yoast SEO

    Thanks for the assistance so far :),
    Jim

    Plugin Author Hardeep Asrani

    (@hardeepasrani)

    @serevinus Hey there!

    Sorry for the delay. Weekends were tough. Anyway, so I took a deep look into this issue (as well into the code from ThirstyAffiliates plugin), it seems we really can’t do anything here.

    It’s a conflict in their code and we can’t put anything to stop it. But luckily, it only happens when you try to increase the button count using the right input.

    If you just use the Progress Bar to increase the number of buttons, it won’t break.

    Also, would recommend you to report this issue to the developer of the plugin as it is appearing in other places too (especially on their own Gutenberg block). πŸ™‚

    Let me know if it helps. πŸ™‚

    Thread Starter serevinus

    (@serevinus)

    Thanks @hardeepasrani,

    Has been a long weekend and week here too so no worries.

    I will raise the issue with them.

    Luckilly I don’t use their block, I only use their link button so I hadnt even noticed their block doesnt work.

    Thanks,
    Jim

    Plugin Author Hardeep Asrani

    (@hardeepasrani)

    @serevinus I’ve already opened a support ticket on their plugin: https://wordpress.org/support/topic/gutenberg-issue-got-github/ πŸ™‚

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error when editing button groups’ is closed to new replies.