Support » Plugin: Invoices for WooCommerce » Error when creating invoice

  • Hello!

    Since the last update, I get this error on the invoice when I create one:

    Fatal error: Uncaught ArgumentCountError: Too few arguments to function Mollie_WC_Helper_GatewaySurchargeHandler::setHiddenOrderId(), 3 passed in /customers/3/4/4/juwelou.be/httpd.www/wp-includes/class-wp-hook.php on line 292 and exactly 4 expected in /customers/3/4/4/juwelou.be/httpd.www/wp-content/plugins/mollie-payments-for-woocommerce/src/Mollie/WC/Helper/GatewaySurchargeHandler.php:28 Stack trace: #0 /customers/3/4/4/juwelou.be/httpd.www/wp-includes/class-wp-hook.php(292): Mollie_WC_Helper_GatewaySurchargeHandler->setHiddenOrderId(209, Object(WC_Order_Item_Product), Object(Automattic\WooCommerce\Admin\Overrides\Order)) #1 /customers/3/4/4/juwelou.be/httpd.www/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters('', Array) #2 /customers/3/4/4/juwelou.be/httpd.www/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #3 /customers/3/4/4/juwelou.be/httpd.www/wp-content/plugins/woocommerce-pdf-invoices/includes/abstracts/abstract-invoice.php(445): do_action('woocommerce_ord...', 209, Object(WC_Order_Item_Product), in /customers/3/4/4/juwelou.be/httpd.www/wp-content/plugins/mollie-payments-for-woocommerce/src/Mollie/WC/Helper/GatewaySurchargeHandler.php on line 28

    What is wrong?

    Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support cengelberts

    (@cengelberts)

    Hi Tom,

    Since the new update of Mollie to 6.3.0 all our customers using Mollie have been getting errors. We have already been in contact with Mollie about this, and we are now working together too fix these errors as soon as possible.
    In the meantime you can download Mollie version 6.2.2 that I will link below. This version still works with our plugin.

    Let me know if this works for you or if you encounter any problems.

    https://wordpress.org/plugins/mollie-payments-for-woocommerce/advanced/
    To download Mollie 6.2.2 go to the link above and scroll all the way down, there you will find a dropdown menu to select Mollie version 6.2.2`

    Hi, same issue here.. Hope this will be fixed asap.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this review.