Support » Plugin: WooCommerce » Error when clicking show cart for first time after putting product in cart

  • WPJohn


    Everytime I put a product in the cart and click show cart, the page starts loading but nothing happens. After some seconds I get an empty wordpress page.

    Clicking again, or clicking while loading, on the show cart button does show a working cart page…
    This is very annoying for new customers.

    This only happens on a new session. (If you test it, you can test it by deleting all cookies/history in your browser. Or close all Chrome windows and then open a new incognito window so you don’t have to delete your whole history).

    When it happens I get the following error in the apache log:
    [Thu May 23 17:36:39 2013] [warn] [client xx.xx.xx.xx] mod_fcgid: stderr: PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 261900 bytes) in /home/domainname/public_html/wp-includes/formatting.php on line 940, referer:

    My php memory limit is 256MB, my memory limit in wp config is also 256M, but tried lower and higher too. Despite the message I don’t think the memory limit is the reason, I think some script or other bug is causing this problem. Besides that I don’t have any problem with my memory limits or other functions. It is only this problem.

    I hope someone can help me. Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • WPJohn


    Here I found another person with the same problem:
    This topic has been created some hours ago, so it looks like this is a recent bug. Maybe something wrong in the latest Woocommerce versio(n) or certain plugins?


    Do you still have this issue? Does your product has variations? I’m suffering from the same error but it only happens when the product has variations, 9 in my case. I’m testing with no plugins, the twenty twelve theme, and 128mb available for memory.

    Hi I have exactly the same problem with all products and PHP 256 MB allowed. It happens only the first time. If i refresh the page, it works perfectly.


    Do you have product variations? The problem on my end only happens with variations.



    I think I found the problem:
    Overlapping rules in the Table Rate Shipping plugin. Some postal codes did overlap. After fixing this I never had the problem again.

    Are you guys also using this plugin? Then check the rules.
    Or other plugins which have rules which are applied somewhere in the shopping process.

    In my case we got to leave just the woocommerce plugin and the twenty twelve theme, just by setting the product to be variable, the cart goes blank on the first product adding. What’s frustrating is that the error is not significant enough.

    @alesub: No, i do not have any variations.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error when clicking show cart for first time after putting product in cart’ is closed to new replies.