Support » Plugin: WooCommerce » Error when apply coupon, loads empty cart page

  • Resolved bigdropgr

    (@bigdropgr)


    Hi,

    I have created a coupon.
    When I apply the coupon on cart page it ajax updating the page and everything disappear.
    You can check the screen shot of the cart page, after I applied a coupon, here https://ibb.co/nD6BUf.

    If I reload the page manualy (F5) the coupon is applied and the new total price is the correct one.

    If I try to remove the coupon on that page I get the same error.

    I tried this both on chrome and firefox, with both admin account and customer account. I get no errors on firefox console.

    What might be the problem?
    Does anyone knows any working fix for this?

    Thank you

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Deactivate all plugins except WooCommerce and switch to the Storefront theme. It should work now.

    Switch back to your theme. If it doesn’t work now, you have a theme problem. As it is a commercial theme, you’ll need to approach the theme vendor’s support service.

    If it does work at this point, reactivate other plugins one-by-one and test to try to identify which one is causing the problem.

    Hi thank you for your reply.

    This is a working website, I can not do this.

    Is there any other way to debug this?

    You could make a copy of the website. There are plugins available to help you do that. Then debug the copy. Its not a certain method because the copy may not be 100% exact.

    https://wordpress.org/plugins/all-in-one-wp-migration/
    and several others.

    Plugin Support Kenin

    (@kbassart)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error when apply coupon, loads empty cart page’ is closed to new replies.