Support » Plugin: NFT Maker » Error when activating plugin

  • Resolved zweifeln

    (@zweifeln)


    Hi, I’m not able activate the Tatum plugin on our website. The error is:

    Parse error: syntax error, unexpected ‘array’ (T_ARRAY), expecting function (T_FUNCTION) or const (T_CONST) in /home/customer/www/tastenfts.com/public_html/wp-content/plugins/tatum/admin/class-tatum-admin.php on line 57

    Is there a dependency that I have to install first? I installed WP Smart Contracts but error is still there.

    Thanks for your help,
    Nadina

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author lukaskotol

    (@lukaskotol)

    Hi!
    Zweifeln, I am working now on fixing your issue. Please give me a little bit time. Once I will solve the problem I will inform you.

    Thanks for your patience.
    Lukas Kotol

    Plugin Author lukaskotol

    (@lukaskotol)

    Hi!
    I think you are using non supported version of PHP which is lower than 5.4.

    The message

    Parse error: syntax error, unexpected ‘array’ (T_ARRAY), expecting function (T_FUNCTION) or const (T_CONST) in /home/customer/www/tastenfts.com/public_html/wp-content/plugins/tatum/admin/class-tatum-admin.php on line 57

    means that you PHP is unable to parse array with new 5.4 PHP Array syntax https://www.php.net/ChangeLog-5.php#PHP_5_4. If you look on the version 5.4.0 you will see

    Added short array syntax support ([1,2,3]), see UPGRADING guide for full details.

    Please update your PHP version to at least 5.4!
    Thanks so much for your response.

    Hi, plugin triggered same fatal error to me too.
    I replaced ‘array’ with function and it triggered next error on same line

    Parse error: syntax error, unexpected ‘$chains’ (T_VARIABLE) in /var/www/wp-content/plugins/tatum/admin/class-tatum-admin.php on line 57

    I got PHP 7.3 and WP 5.7.2 installed

    Plugin Author lukaskotol

    (@lukaskotol)

    Hi, @digissues, I think you are using an older version of PHP than 5.4, could you please double-check it? As I referred this is often caused when you are running low PHP version.

    Plugin Author lukaskotol

    (@lukaskotol)

    Could you please @digissues also try version 7 of PHP? Thanks.

    csabahalasz73

    (@csabahalasz73)

    Hi,
    I use PHP version 7.3.6, but I got the same error message when I tried to activate it. Can you please help me to fix it?

    Thank you.

    Plugin Author lukaskotol

    (@lukaskotol)

    Hi,
    @csabahalasz73, the error is that I am expecting you to use PHP version at least 7.4. I will downgrade it to 7.0 PHP. Let me fix it in minute!

    csabahalasz73

    (@csabahalasz73)

    Hi,
    @lukaskotol , thank you. Ok. no problem. I wait.

    Plugin Author lukaskotol

    (@lukaskotol)

    Hi,
    @csabahalasz73 now it should plugin work normally even with PHP 7.0.
    Please, try to delete and install the plugin again.
    Thanks and sorry for the issue.
    If you will have any problem in future, let me know about it.
    Lukas Kotol

    csabahalasz73

    (@csabahalasz73)

    Hi,
    @lukaskotol thank you. It seems ok, now. thank you, again.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Error when activating plugin’ is closed to new replies.