Support » Plugin: Read More Without Refresh » Error when activating plug in

  • Hello there 🙂

    I will give you all the details of my problem, which seems unusual.

    I am using your plugin since one year or so, updating to the latest versions each time as recommended. In one of your last versions the color of “read more” and “read less” button changed and also an underline was added, which was ok, however, in order to fit my website colors and style, I managed to change it by editing the file. Also I was using different words sometimes like “expand” and “hide” in the basic page editor.

    The last couple of days (I really can’t remember exactly if it was the same day of your last update) there was a big mess at my website, everything was wrong, headers, fonts, sidebars, widgets, all! I made contact with my template support team and they checked on it and informed me that it was because of the “Read More without refresh” plugin. Just to be sure, I tried it myself and really when I activate it, I loose all of my appearance settings as said before and when I deactivate it, everything looks fine.

    I would like to continue using your plugin first because it’s super cool and easy to use, but also because I have it in more than 100 posts and pages and I would have to erase the [read more=”…read more” less=”read less”] line from everywhere.

    Until now, I have tried to completely delete it and reinstall it, but it didn’t work.

    Sorry for the long message, I am not a professional designer, so I had to explain my issue using my own words.

    Any suggestions?

    Thank you in advance

    Christos

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author George Gkouvousis

    (@gkouvousisg)

    Hi Christos.

    Unfortunately, in such cases, noone can tell a thing without taking a look at the website/errorlog etc.

    I can go beyond levels of basic support by taking a look there.

    [email redacted]

    I’m am 100% sure you mean well but please never ask for credentials on these forums.

    http://codex.wordpress.org/Forum_Welcome#The_Bad_Stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

    Same problem here. It’s messing with visual composer. So far I deactivated the plugin. Hope you come up with a solution soon.

    ofeguadalupe

    Plugin Author George Gkouvousis

    (@gkouvousisg)

    @ofeguadalupe , this plugin is made to work with WordPress default post editor. Visual Composer is not using WordPress default post editor.
    Thus, this is not a compatibility issue at all. OP reports another situation, which I’m not able to reproduce at all. The fact that I continuously receive positive feedback over the days by new installation webmasters, on fully up to date WordPress cores/plugins combo, makes me think that this is a very specific scenario and we have to deal a plugin-to-plugin compatibility.

    @kechristos , can you disable all plugins except mine and let me know if it works fine for you? If it does, I want you to enable them back one by one and do some regular checks for issues after each one’s activation.

    Thread Starter kechristos

    (@kechristos)

    I tried disabling all plugins except “read more” and still there is a problem even if it’s the only one activated.

    Plugin Author George Gkouvousis

    (@gkouvousisg)

    Did you try changing theme to the default one?

    Im asking just to eliminate every possible factor. Sounds like a db issue at this time, since my demo uses exactly the same version of the plugin and its behavior is normal: http://apps.8web.gr/demos/wordpress-read-more-without-refresh-plugin/

    Thread Starter kechristos

    (@kechristos)

    Obviously, I can assume that if I change the theme, it will probably work fine. I use your plugin in another theme as well without issues. So, my question would be what if there is an issue only with the particular theme? What would be the next step?

    Let me also ask you what is exactly a db issue?

    If you have any ideas, feel free to suggest.

    Thank you for your time and the support.

    C.

    Plugin Author George Gkouvousis

    (@gkouvousisg)

    So in your case, the issue is clear and is related to the theme and/or its plugins.
    My plugin is really a small and simple one, with a bunch lines of code, so what makes the situation complicated there is your theme.
    Have you asked your theme developer regarding the issue aswell?
    Im not allowed to ask for credentials share here.

    Thread Starter kechristos

    (@kechristos)

    As I said in the first place, I made contact with the support team of my theme. They checked on it and informed me that it was because of the “Read More without refresh” plugin. I don’t think that they tried to solve it, I can assume that they just realized it by disabling-enabling procedure.

    One other thing is that before the problem, I changed some overall colors from the Theme Settings Tab. I dont know if there is any relativity.

    Anyway, as long as I understand it must be too complicated and one should go deep enough, making tests and combinations in order to solve it.

    Unfortunately, if there isn’t any easy solution, I should replace your plugin, even though I think it’s the best of its kind. I will also leave a good review, since I appreciate your work and your support. I am not disappointed, just unlucky.

    If you ever end up with an idea, let me know.

    All the best

    Plugin Author George Gkouvousis

    (@gkouvousisg)

    Thanks for your kind words. They are highly appreciated.

    Please contact me directly at my email (found in the plugin’s info).
    I’ll be more than happy to help here.

    Hosts usually offer no managed services, but you are not alone there.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error when activating plug in’ is closed to new replies.