Support » Plugins and Hacks » [Resolved] Error Warning on activating plugin

[Resolved] Error Warning on activating plugin

  • When activating the plugin I get this error:

    Warning: is_readable(): open_basedir restriction in effect. File(/home/www/web222/html/_wp/site2014/wp-content/plugins/content-progress/content-progress.php/content-progress-de_DE.mo) is not within the allowed path(s): (/home/www/web222/html/:/home/www/web222/phptmp/:/home/www/web222/files/:/home/www/web222/atd/:/usr/local/php5.4-fcgi/lib/php/:/usr/local/php5.4/pear/:/usr/bin/) in /home/www/web222/html/_wp/site2014/wp-includes/l10n.php on line 457

    Could you please fix this?

    WP 3.9.1 Network installation (blogs in subdirectories)


Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Joe Dolson


    That’s interesting. If I’m reading the error right, you’ve added a German translation to Content Progress, but have placed it in the wrong directory. Translation files should be in the ‘lang’ directory.

    This could also indicate a file permissions issue, where your uploaded translation file has different permissions than the default installed files.

    Either way, there’s nothing I can do about this, since it relates to a file I didn’t provide. If you want to provide me with your translation file, I would love to add it to the plugin so that others can benefit from it.

    No, I haven’t made anything at all (no file changes, no translations) – just activate your plugin “as is”.
    And then at the top of my backend appears this error.

    I deactivated all other plugins – without success.
    Using HUEMAN theme from http://alxmedia.se/themes/hueman/

    It seems as if the network path is not right?
    Does the plugin try to add a content-progress-de_DE.mo file?
    I have no such file in my ftp plugin’s folder, only your .pot:


    and the “lang” folder:

    Plugin Author Joe Dolson


    No, it doesn’t add that file, or attempt to. It seems like your installation is looking for it, and throwing an error on failing to find it.

    Looking for the file is a normal part of what WordPress does, in checking for translations, but is don’t know why it would throw an error on failing to find it.

    Looking at the path, it looks like an invalid path, which could be the source of the problem. It doesn’t look like Content Progress is registering an invalid path for languages, however, so I’m not sure why that would be.

    Is this a stand alone install or a multisite network?

    it’s a multisite installation with sub-blogs in sub-directories. I’ve never seen this error with no matter what plugin … very strange …

    Plugin Author Joe Dolson


    I’ve never seen this either, but I’ll see if I can reproduce this in that type of environment.

    Thanks a lot, appreciate your help!

    Plugin Author Joe Dolson


    I haven’t been able to reproduce this; I’ve set up a multisite installation in German, added Content Progress – but can’t reproduce the error.

    An open_basedir restriction means that your server is restricting access to directories, so you may want to talk to your host or server manager to see if they have a suggestion; a change to your httpd configuration file may be what you need.

    Does this happen if you install other new plug-ins?

    No, I haven’t seen this at all

    I add to this issue, since I face it as well.

    My current setup is:

    Latest WordPress Version
    Latest Content Progress Version
    OS: Ubuntu 12.04 LTS
    Plesk 11
    open_basedir on for security reasons

    I have a single WordPress Installation and so far only Timthumb (fixed it) had issues and Content Progress.

    There seems to be an issue with reading the lang files properly, because the path “…/wp-content/plugins/content-progress/content-progress.php/content-progress-de_DE.mo” seems to be invalid. It causes high loading times :/

    I surely am not a PHP Coder, but I think it comes down to this line (and what is attached to it):

    load_plugin_textdomain( ‘content-progress’, false, dirname( plugin_basename( __FILE__ ) . ‘/lang’ ) );

    I fixed it.


    load_plugin_textdomain( ‘content-progress’, false, dirname( plugin_basename( __FILE__ ) . ‘/lang’ ) );


    load_plugin_textdomain( ‘content-progress’, false, dirname( plugin_basename( __FILE__ ) . ‘./lang’ ) );

    The dot is missing before /lang. This results in a directory resolving issue on Linux Machines.

    Plugin Author Joe Dolson


    That sounds like plugin_basename( __FILE__ ) isn’t returning a result. Can you verify that?

    I added the dot to ‘/lang’ to have it read ‘./lang’ and since then I have no further issues and also error_log from Apache2 no longer spits out anything regarding Content Press having an issue with open_basedir.

    Plugin Author Joe Dolson


    Yes, I understand that. Can you confirm whether plugin_basename( __FILE__ ) returns a result in your installation?

    How do I check that? I am sadly not that highly experienced with WordPress nor with debugging something :/

    Plugin Author Joe Dolson


    You’d need to be able to add a line of code to echo the value of plugin_basename( __FILE__ ) into the plug-in; would you be comfortable doing that?

    Somewhere in an HTML context, you’d add:

    <?php echo "Plugin Basename: ".plugin_basename( __FILE__ ); ?>

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Error Warning on activating plugin’ is closed to new replies.