Support » Plugin: Favorites » Error “Warning: in_array() expects parameter 2 to be array, null given in”

  • I’m getting this message above the favorite button, as well as above the list on my sidebar displaying all my favorite posts (the message appears for each favorited post, so it can be multiple – dozens – of times, depending on the user):

    Warning: in_array() expects parameter 2 to be array, null given in /home/…/public_html/wp-content/plugins/favorites/app/Entities/User/UserRepository.php on line 188

    The button works just fine, but these messages won’t go away.
    What’s the matter and how to fix this?
    Thank you.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m getting same message all of a sudden. What’s the fix? Creator gone silent!

    ericgolftourney

    (@ericgolftourneygmailcom)

    Any update on this? Is there a workaround?

    Hello,

    Same problem on my website …
    Is there a solution?

    Thank’s

    Thread Starter breathelifein

    (@biellebrunner)

    Really? No one? =/

    No response from developer, but thanks to Aristeides Stathopoulos in GitHub, replacing define(‘WP_DEBUG’, false); in WP-config file does the trick…

    ini_set(‘display_errors’,’Off’);
    ini_set(‘error_reporting’, E_ALL );
    define(‘WP_DEBUG’, false);
    define(‘WP_DEBUG_DISPLAY’, false);

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error “Warning: in_array() expects parameter 2 to be array, null given in”’ is closed to new replies.