Support » Plugin: Yoast SEO » Error Warning: Class __PHP_Incomplete_Class has no unserializer

  • Yoast SEO sitemap used to work fine until this week:

    Warning: Class __PHP_Incomplete_Class has no unserializer in /home/content/p3pnexwpnas14_data02/95/3039995/html/wp-content/object-cache.php on line 520

    All sitemaps are now broken and returning this error. Anyone knows how to fix this?

    https://wordpress.org/plugins/wordpress-seo/

Viewing 15 replies - 16 through 30 (of 31 total)
  • Same problem for me. If I go to Google XML sitemaps then my post-sitemap file works. But if I go back to Yoast I get this exact error. My page-sitemap file works fine. I have managed WordPress through GoDaddy as well.

    ****** SOLUTION *********

    This fixed the symptom but not the root of the problem, which is something on the Godaddy Managed WordPress side.

    I got this fix after several hours with GD support. As mentioned in other posts there is a problem with the GD caching feature, until they fix it you can do this!

    SOLUTION (for Godaddy Managed WordPress Sites):

    1) FTP into your wp-content folder
    2) rename “object-cache.php” to “object-cache-DISABLED.php”
    3) flush your site cache using the GD menu function at the top of your WP admin CP
    4) get a beer

    The more sites you have to fix, the more beers you will need.
    Happy hacking!

    Thank you KarlAlexander-VQZ, While I did not have a problem with YoastSEO or my sitemaps. I have had several other caching problems on many of my sites that I have hosted on GoDaddy managed WP hosting. Funny errors like the one posted here, to my nav bars not working properly and other little things not propagating correctly. I have been racking my brain on how to fix this as GoDaddy is no help. You must have a lot of patience to stay on that long to get a fix out of them.

    I tried this fix you posted:
    SOLUTION (for Godaddy Managed WordPress Sites):

    1) FTP into your wp-content folder
    2) rename “object-cache.php” to “object-cache-DISABLED.php”
    3) flush your site cache using the GD menu function at the top of your WP admin CP
    4) get a beer

    And it worked perfectly on all my sites as well as it shaved 1-2 seconds of load time from my sites. Oh and the beers made it very enjoyable to get done. Thank goodness it was part of the solution.

    Thank you again.

    I am working through this same error and was optimistic that this would work. But the above steps did not work for me. I tried to GoDaddy support and they had absolutely nothing to offer.

    Anyone else have some possible solutions

    Many thank to KarlAlexander-VQZ. It works like a champ.

    KarlAlexander-VQZ you are a true hero and should be hoisted upon shoulders.

    Been looking for this solution for months.

    I have been experiencing the same error for almost a few weeks sporadically on 3 of my 4 sites, I finally got someone at Godaddy who knew what was going on. It appears that with WP 4.5 there was a main error with “Object Cache” that in turn was giving errors on certain plugins. I was advised that “Mark” the creator of WP was working on a fix
    The rep went into my dashboard on all 3 sites under WP content folder and disabled the object cache. He did this under the section Object_Cache and renamed it
    He said that once there is a new automatic Wp update then it should probably be OK and not mess it up as hopefully that will contain the fix.

    Why this is happening on some sites and not others? Who the heck knows but I am hoping this resolves it.

    ed

    (@wesleysoccer)

    wow thanks @karlalexander-vqz

    Thank you @karlalexander-vqz!

    Thanks @karlalexander-vqz
    Should i need to again enable Object-Cache file

    For goodness sake, how has this not been fixed yet? I thought YoastSEO was a proper plugin. Any suggestions of non buggy alternatives?

    @maccas83
    for goodness sake, it’s working fine on all our websites.

    This is a support forum, not a comment forum, as such. If you have an actual issue on *your* particular install, you are best served by starting a new topic for help and feedback.

    Yoast SEO *is* a proper plugin used by vast number of sites of all shapes and sizes. Why would you think it’s not?

    If you want to try other plugins, there are plenty in the WordPress repository you can play with. Not all WP plugins of any kind work in all settings, as in the case of this thread a bug with GoDaddy, and not the plugin.

    As with all things, you need to try each option out and see if it works for you. If not, try something else.

    Helps to read through the actual topic to see what the issue being addressed actually is. If it does not apply to you, posting a tail-end comment unrelated to the topic, does nothing to help or assist yourself or others.

    @maccas83 this is a GoDaddy issue related to their cache setup, see comment #3. If you don’t need the sitemap feature, you can disable it and everything else should work fine. I’ve done this for one of my sites. There are other sitemap plugins you can use instead.

    What a pain.. spent hours with GD support and they finally gave me this link. We had the issue solved except for mobile browsers. They sent me the link to this thread and after changing the plugin file name it appears to be working. THANK YOU!

    Disabling the object cache entirely doesn’t seem like a good solution. Yoast SEO and GoDaddy’s managed hosting seem to be the common threads. But unless there’s a GoDaddy plugin generating the class in the first place, the issue must like with Yoast SEO, no?

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘Error Warning: Class __PHP_Incomplete_Class has no unserializer’ is closed to new replies.