Support » Plugin: WooBuddy -> WooCommerce BuddyPress Integration » Error: Warning: array_key_exists() expects parameter 2 to be array … line 54

  • Hi – I’m testing a new woocommerce variable product which includes 3 variations. The variations are 2 different Learndash courses plus a third variation which includes both of the LD courses. The site also uses buddyboss theme/platform for discussion groups, so I’m using the WC Buddypress integration as well. Payments go through and email confirmation messages are received as normal, but this error appears on the confirmation page on the website SOMETIMES (not always):

    Warning: array_key_exists() expects parameter 2 to be array, bool given in /home/customer/www/spiritualtransformationcourses.com/public_html/wp-content/plugins/wc4bp/class/wc4bp-notifications.php on line 54

    so the error is occurring in the wc 4 buddypress plugin on line 54. but why is it happening and how do I fix this??

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter melanyh

    (@melanyh)

    more info: the error message only seems to appear when using the Paypal payment method, and not when using the Stripe payment method.

    Any help would be much appreciated! thank you

    Any solutions ? I get the same error message here :/

    • This reply was modified 6 months, 1 week ago by designboxcom.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Error: Warning: array_key_exists() expects parameter 2 to be array … line 54’ is closed to new replies.