Support » Plugin: Electric Studio Download Counter » error / warning after upgrade to 2.1

  • hey Gabor,

    thanks for this awesome plugin. I was using version 2.0.2 which worked like a charm. Unfortunately i experienced a bug after upgrading to 2.1. Here’s my error-message:

    Warning: explode() expects parameter 2 to be string, array given in C:\xampp\htdocs\aksgesundheit\wp-content\plugins\electric-studio-download-counter\electric-studio-download-counter.php on line 635

    i already deactived all other plugins to see if there’s a conflict – but no success. As you can see i’m still developing local so there’s no link i could provide you.

    maybe you can help me out with a solution?
    Thanks a lot,
    matteo

    http://wordpress.org/plugins/electric-studio-download-counter/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey Matteo,

    Ditch that plugin (I did) and use this one, it is way more functional. I was able to easily add in my downloads and set the counter to match the particular files download count.

    WordPress Download Manager

    Hey flashbuddy,

    i already know that plugin – but it’s way too big for my needs. I did my own kind of “plugin” with custom post types.

    Same error for me on several client sites.
    Warning: explode() expects parameter 2 to be string, array given in /home/oppor3/public_html/dev/wp-content/plugins/electric-studio-download-counter/electric-studio-download-counter.php on line 635

    For now I’ve commented out the end of 634 and all of 635.

    'ds_nonce' => $this->datesearch_nonce/*,
                'tracked' => json_encode( explode( ',', get_option( 'esdc_file_types' ) ) )*/

    Be forewarned that once you do that you can’t access the file types then via Javascript.

    I’m having the same problem

    @schutzsmith

    that did the trick for the moment – thank’s a lot

    Plugin Author Electric Studio

    (@electric-studio)

    There’s always been an issue when trying to count anything else but standard “a href” links, so if you use JS to perform the download, it might not work properly.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘error / warning after upgrade to 2.1’ is closed to new replies.