• Hi

    While investigating why backups were not being sent to Dropbox, on running the verify settings check on remote storage, I got an error: email report lists:-

    Error Details
    =============
    An error of type E_ERROR was caused in line 194 of the file /home/xxxxxxxxxxxx/public_html/wordpress/wp-content/plugins/xcloner-backup-and-restore/vendor/monolog/monolog/src/Monolog/Handler/AbstractHandler.php. Error message: Uncaught Error: Undefined class constant ‘Monolog\Utils::DEFAULT_JSON_FLAGS’ in /home/xxxxxxxxxxxx/public_html/wordpress/wp-content/plugins/xcloner-backup-and-restore/vendor/monolog/monolog/src/Monolog/Handler/AbstractHandler.php:194
    Stack trace:
    #0 /home/xxxxxxxxxxxx/public_html/wordpress/wp-content/plugins/xcloner-backup-and-restore/vendor/monolog/monolog/src/Monolog/Handler/AbstractHandler.php(113): Monolog\Handler\AbstractHandler->getDefaultFormatter()
    #1 /home/xxxxxxxxxxxx/public_html/wordpress/wp-content/plugins/xcloner-backup-and-restore/vendor/monolog/monolog/src/Monolog/Handler/AbstractProcessingHandler.php(37): Monolog\Handler\AbstractHandler->getFormatter()
    #2 /home/xxxxxxxxxxxx/public_html/wordpress/wp-content/plugins/xcloner-backup-and-restore/vendor/monolog/monolog/src/Monolog/Logger.php(344): Monolog\Handler\AbstractProcessingHandler->handle(Array)
    #3 /home/xxxxxxxxxxxx/public_html/wordpress/wp-content/plugins/xcloner-backup-and-restore/vendor/monolog/monolog/src/Monolog/Logger.php(642): Monolo

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support jimiero

    (@jimiero)

    Hello,

    Are you using latest XCloner version?

    Regards

    Thread Starter Easton Bavents

    (@microbe)

    Using Version 4.2.11

    Plugin Contributor ovidiul

    (@ovidiul)

    Please try and upgrade or reinstall the XCloner Google Drive plugin as there might be a conflict with a previous version.

    Let me know if you still have issue.

    Thread Starter Easton Bavents

    (@microbe)

    Hi, even after upgrading I continued to have problems. Backups were not running and I was unable to access the main XCloner dashboard page (I could see the other pages though, Schedules etc).

    I eventually traced the issue to a conflict with WP-Optimize. I have switched off the WP-Optimize Minify option, and now have access to the dashboard. I will now test that backups are running normally and to schedule.

    I tried excluding XCloner Javascript from Minification, that had no effect. I run WP-Optimize and XCloner together on other sites without problems, so I do wonder if the real culprit may be some other plugin interfering with WPO and XCloner.

    Thanks for your help with this.

    Edit: I have tested on other sites running WP-Optimize and XCloner. There does appear to be an issue if Minify is active.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error verifiying remote storage’ is closed to new replies.