Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Error: User does not have sufficient permissions for this account.

  • Resolved williammorrison


    Aloha πŸ™‚

    I’ve tried everything but I can’t get Site Kit to connect to GA with this particular website.

    Search Console connects effortlessly over and over again.

    the Tracking ID begins with UA-4443…

    Site Kit connects perfectly with the same user credentials on a dozen other sites.

    No GA data has been collected since May 9.

    I’ve cleared cache, gone incognito, multi browsers, reset Site Kit, reinstalled Site Kit …

    I’m at a loss – can you please help?

    Thank you πŸ™‚

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support James Osborne


    @williammorrison-1 Sorry to hear you’ve been encountering problems with connecting the Analytics module. We’re currently looking into the below GitHub issue, which may possibly be related:

    So we can troubleshoot further can you share the following:
    – Your Site Health information
    – Are you using the same hosting provider as you use for the other sites that connect successfully? If not can share your current host?
    – The tracking code that begins with UA-4443…, is that one of your existing tracking property IDs when you check your Analytics account?

    Plugin Support James Osborne


    Thread Starter williammorrison


    ALoha James.

    Thanks for your help πŸ™‚

    1) The host is Flywheel. No issues with other sites hosted by Flywheel.

    2) The tracking code (Osher / UA-4443…) is for the account which Site Kit is having trouble connecting to. I confirmed it in GA.

    3) Monster Insights plugin is connecting to GA without issue. Only Site Kit is failing to connect, and oddly, only to this one account (UA-4443…).

    and here is Sit Health:

    ### wp-core ###

    version: 5.4.1
    site_language: en_US
    user_language: en_US
    timezone: Pacific/Honolulu
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true

    ### wp-paths-sizes ###

    wordpress_path: /www
    wordpress_size: 45.97 MB (48206525 bytes)
    uploads_path: /www/wp-content/uploads
    uploads_size: 3.34 MB (3501632 bytes)
    themes_path: /www/wp-content/themes
    themes_size: 1.98 MB (2080731 bytes)
    plugins_path: /www/wp-content/plugins
    plugins_size: 59.39 MB (62275616 bytes)
    database_size: 12.28 MB (12877824 bytes)
    total_size: 122.97 MB (128942328 bytes)

    ### wp-dropins (1) ###

    db-error.php: true

    ### wp-active-theme ###

    name: GeneratePress (generatepress)
    version: 2.4.2
    author: Tom Usborne
    parent_theme: none
    theme_features: fl-theme-builder-headers, fl-theme-builder-footers, fl-theme-builder-parts, automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, custom-logo, menus, editor-style, widgets
    theme_path: /www/wp-content/themes/generatepress

    ### wp-plugins-active (15) ###

    Admin Columns: version: 4.1.6, author:
    Autoptimize: version: 2.7.2, author: Frank Goossens (futtta)
    Beaver Builder Plugin (Pro Version): version:, author: The Beaver Builder Team
    Beaver Themer: version: 1.3.1, author: The Beaver Builder Team
    Custom Twitter Feeds Pro Developer: version: 1.8, author: Smash Balloon
    Disable Comments: version: 1.10.2, author: Samir Shah
    Email Address Encoder: version: 1.0.19, author: Till KrΓΌss
    Google Analytics for WordPress by MonsterInsights: version: 7.10.4, author: MonsterInsights
    GP Premium: version: 1.10.0, author: Tom Usborne
    Redirection: version: 4.8, author: John Godley
    Site Kit by Google: version: 1.8.1, author: Google
    Smush: version: 3.6.3, author: WPMU DEV
    SVG Support: version: 2.3.18, author: Benbodhi
    TinyMCE Advanced: version: 5.4.0, author: Andrew Ozz
    WP Accessibility: version: 1.7.1, author: Joe Dolson

    ### wp-plugins-inactive (1) ###

    The SEO Framework: version: 4.0.7, author: The SEO Framework Team

    ### wp-media ###

    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-06-15
    imagick::RESOURCETYPE_AREA: 31 GB
    imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    imagick::RESOURCETYPE_FILE: 768
    imagick::RESOURCETYPE_MAP: 31 GB
    gd_version: 2.2.5
    ghostscript_version: unknown

    ### wp-server ###

    server_architecture: unknown
    httpd_software: Flywheel/4.1.0
    php_version: 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 4000
    time_limit: 30
    memory_limit: 200M
    max_input_time: 60
    upload_max_size: 300M
    php_post_max_size: 300M
    curl_version: 7.47.0 OpenSSL/1.0.2g
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true

    ### wp-database ###

    extension: mysqli
    client_version: mysqlnd 5.0.12-dev – 20150407 – $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $

    ### wp-constants ###

    WP_CONTENT_DIR: /www/wp-content
    WP_PLUGIN_DIR: /www/wp-content/plugins
    WP_DEBUG: false
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    ### google-site-kit ###

    version: 1.8.1
    wp_version: 5.4.1
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    active_modules: site-verification, search-console, analytics
    openid: βœ… βœ… βœ… βœ… βœ… βœ… βœ… βœ… βœ…
    analytics_account_id: none
    analytics_property_id: none
    analytics_profile_id: none
    analytics_use_snippet: yes

    Plugin Support James Osborne


    @williammorrison-1 Many thanks for providing the additional information. I’ll keep you updated here as we continue to investigate the related GitHub issue.

    Thread Starter williammorrison


    Much thanks James πŸ™‚

    It seems odd that Monster Insights can connect without issue, while Site Kit cannot.

    I would much prefer to Site Kit if we can get things resolved πŸ™‚

    Are there any account settings in Google Analytics itself that I should explore?

    You the best!

    Plugin Support James Osborne


    @williammorrison-1 Many thanks for the response, and troubleshooting assistance. If you’d like to share any console errors that may be of use.

    In addition if you’re able to determine any differences between the accounts you are able to connect successfully that may be of use as we try to recreate the same issue.

    Thread Starter williammorrison


    The same account Gmail account (cssweb) is both succeeding and failing.

    Site Kit just failed to connect to GA for another site using this account.

    Same error for this second site “Error: User does not have sufficient permissions for this account.”

    Thread Starter williammorrison


    For the second failing site, I get this error when I try to connect to GA via Site Kit … when Monster Insights plugin is activated and connected to GA.

    “Error: We’ve detected there’s already an existing Analytics tag on your site (ID UA-4887xxxxx), but your account doesn’t seem to have access to this Analytics property. You can either remove the existing tag and connect to a different account, or request access to this property from your team.”

    The GA ID is correct, but Site Kit seems to “not trust” my account?

    Only Site Kit – Monster Insights trusts it just fine.

    Plugin Support James Osborne


    @williammorrison-1 Very useful insights, appreciate you sharing while we are still investigating this issue. When it comes to the Google account you used to setup Site Kit (the same account used to connect the Analytics module) I assume it’s a standard Google account as opposed to a GSuite account?

    Site Kit just failed to connect to GA for another site using this account.

    Is this consistent when trying to select the same Analytics account on other sites?

    Thread Starter williammorrison


    I think itΚ»s a GSuite account – associated with the University of HawaiΚ»i.

    This same account is being used – and is working perfectly – for Site Kit connections to the Analytic module on 11 other sites.

    @williammorrison-1 thanks for the info!

    For the Analytics account and property with the issue, could you confirm the levels of user permissions the Google Account (email) you’re using with Site Kit has under the following in the Admin area of the Analytics account:

    1) Account User Management
    2) Property User Management
    3) View User Management

    Here’s an example of what the permissions screens will look like. Special note that if providing screenshots, please obscure/hide email if there is no name for the user.

    Thread Starter williammorrison


    Aloha Renne,

    Account permissions look identical for both the GA accounts that Site Kit is able to connect to, and the two that it is failing to connect to (highlighted in red)

    Property and View permissions look identical across all accounts.

    Account permission are Direct

    Property and View are Inherited


    @williammorrison-1 really appreciate the confirmation! We’ll share this with the team and update you when we have more information.

    Plugin Support Luckyna San


    Hello @williammorrison-1 ,
    We recently released a fix for this issue in the most recent version 1.12.0. Can you please update to the new version and inform us if the issue persists? Thank you.

    Thread Starter williammorrison


    It worked! It worked! It worked! Perfectly πŸ™‚

    You guys are AWESOME!

    Much thanks from Hawai’i.


Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Error: User does not have sufficient permissions for this account.’ is closed to new replies.