Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Error: User does not have sufficient permissions for this account.

  • Resolved Turritops

    (@turritops)


    I have 9 wordpress sites defined in Analytics under three different accounts. They all have one and only one administrator and it’s the same admin for all accounts, properites and views. I have no problem connecting six of the sites to Site Kit Analytics but three gives the error “Error: User does not have sufficient permissions for this account.”. This only affect Analytics, Search Console is working for all nine.

    The three error sites/properties have all in common that they have been moved from their own accounts to a common account. During the move I selected to replace all rights and I can’t see any differences in the rights between the three that gives an error and a fourth property in the account that is working. Full heritage is active so the same rights is applied on all four properties. Please advise.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Renee Johnson

    (@reneesoffice)

    @turritops thanks for your topic and the details. Some checks that may help:

    1) Is the Google account you’re using with Site Kit the same as the administrator for the properties in your Analytics account (including the three sites/ properties that have the error)?

    2) For a site with the error, in an incognito browser could you reset Site Kit, proceed through the setup process and attempt to connect Analytics.

    3) If the error persists, could you provide screenshots of any browser console errors you might see?

    You can provide a link to screenshots using a service like Imgur or Jumpshare.

    Thread Starter Turritops

    (@turritops)

    Thank you for your answer.

    1. Yes. “They all have one and only one administrator and it’s the same admin for all accounts, properites and views.” I use the same account when connecting to Google Analytics and it works for six out of nine sites.
    2. Same result.
    3. https://imgur.com/a/PgKI1A2

    Plugin Support Renee Johnson

    (@reneesoffice)

    @turritops thanks for the follow up/ confirmation. It sounds like you’re experiencing this issue that we’re currently investigating.

    If possible, could you provide your Site Health information for a site with the issue and a site without the issue on the common account to compare? There is Site Kit specific information that will let us know the status of the connection as well.

    Thread Starter Turritops

    (@turritops)

    @reneesoffice thank you for the update! I’ll provide health info for two sites. Blog.elof.com is working and the “native” property for the Privat account. [ redundant link removed ] is not working and the property is moved from it’s own account to the Privat account.

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: sv_SE
    user_language: sv_SE
    timezone: +00:00
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/blog.elof.com
    wordpress_size: 92,69 MB (97196628 bytes)
    uploads_path: /var/www/blog.elof.com/wp-content/uploads
    uploads_size: 262,41 MB (275156361 bytes)
    themes_path: /var/www/blog.elof.com/wp-content/themes
    themes_size: 2,68 MB (2810402 bytes)
    plugins_path: /var/www/blog.elof.com/wp-content/plugins
    plugins_size: 23,22 MB (24343882 bytes)
    database_size: 9,75 MB (10223616 bytes)
    total_size: 390,75 MB (409730889 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Fifteen (twentyfifteen)
    version: 2.6
    author: WordPress-teamet
    author_website: https://wordpress.org/
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, custom-background, editor-style, editor-styles, wp-block-styles, responsive-embeds, editor-color-palette, customize-selective-refresh-widgets, custom-header, widgets
    theme_path: /var/www/blog.elof.com/wp-content/themes/twentyfifteen
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.3, author: WordPress-teamet
    
    ### wp-plugins-active (8) ###
    
    AddToAny Share Buttons: version: 1.7.40, author: AddToAny
    Easy WP SMTP: version: 1.3.9.3, author: wpecommerce, alexanderfoxc
    FancyBox for WordPress: version: 3.2.7, author: Colorlib
    GDPR Cookie Consent: version: 1.8.8, author: WebToffee
    No Category Base (WPML): version: 1.3, author: Marios Alexandrou
    Site Kit by Google: version: 1.8.1, author: Google
    SyntaxHighlighter Evolved: version: 3.5.4, author: Alex Mills (Viper007Bond)
    Wordfence Security: version: 7.4.7, author: Wordfence
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-11-12 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 8 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 8 GB
    	imagick::RESOURCETYPE_MEMORY: 4 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.1.1
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-178-generic x86_64
    httpd_software: Apache/2.4.18 (Ubuntu)
    php_version: 7.0.33-0ubuntu0.16.04.14 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 16M
    php_post_max_size: 16M
    curl_version: 7.47.0 OpenSSL/1.0.2g
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.30-0ubuntu0.16.04.1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/blog.elof.com/wp-content
    WP_PLUGIN_DIR: /var/www/blog.elof.com/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### google-site-kit ###
    
    version: 1.8.1
    php_version: 7.0.33-0ubuntu0.16.04.14
    wp_version: 5.4.1
    reference_url: https://blog.elof.com
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    active_modules: site-verification, search-console, analytics
    required_scopes: 
    	openid: ✅
    	https://www.googleapis.com/auth/userinfo.profile: ✅
    	https://www.googleapis.com/auth/userinfo.email: ✅
    	https://www.googleapis.com/auth/siteverification: ✅
    	https://www.googleapis.com/auth/webmasters: ✅
    	https://www.googleapis.com/auth/analytics: ✅
    	https://www.googleapis.com/auth/analytics.readonly: ✅
    	https://www.googleapis.com/auth/analytics.manage.users: ✅
    	https://www.googleapis.com/auth/analytics.edit: ✅
    search_console_property: https://blog.elof.com/
    analytics_account_id: 5979••••
    analytics_property_id: UA-5979••••••
    analytics_profile_id: 9800••••
    analytics_use_snippet: yes
    </blockquote>
    
    <blockquote>
    ### wp-core ###
    
    version: 5.4.1
    site_language: sv_SE
    user_language: sv_SE
    timezone: Europe/Stockholm
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/www.lejongapet.se
    wordpress_size: 341,75 MB (358348668 bytes)
    uploads_path: /var/www/www.lejongapet.se/wp-content/uploads
    uploads_size: 1&nbsp;009,51 MB (1058548977 bytes)
    themes_path: /var/www/www.lejongapet.se/wp-content/themes
    themes_size: 7,83 MB (8213667 bytes)
    plugins_path: /var/www/www.lejongapet.se/wp-content/plugins
    plugins_size: 39,66 MB (41583065 bytes)
    database_size: 14,80 MB (15518800 bytes)
    total_size: 1,38 GB (1482213177 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Fifteen (twentyfifteen)
    version: 2.6
    author: WordPress-teamet
    author_website: https://wordpress.org/
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, custom-background, editor-style, editor-styles, wp-block-styles, responsive-embeds, editor-color-palette, customize-selective-refresh-widgets, custom-header, widgets
    theme_path: /var/www/www.lejongapet.se/wp-content/themes/twentyfifteen
    
    ### wp-themes-inactive (6) ###
    
    Twenty Eleven: version: 3.4, author: WordPress-teamet
    Twenty Fourteen: version: 2.8, author: WordPress teamet
    Twenty Nineteen: version: 1.5, author: WordPress-teamet
    Twenty Sixteen: version: 2.1, author: WordPress-teamet
    Twenty Thirteen: version: 3.0, author: WordPress-teamet
    Twenty Twenty: version: 1.3, author: WordPress-teamet
    
    ### wp-plugins-active (16) ###
    
    AddToAny Share Buttons: version: 1.7.40, author: AddToAny
    Blog Post Filter: version: 1.1.0, author: ammar.shahraki
    Duplicate Post: version: 3.2.4, author: Enrico Battocchi
    Easy Table: version: 1.8, author: Takien
    Easy WP SMTP: version: 1.3.9.3, author: wpecommerce, alexanderfoxc
    Embed Plus for YouTube - Gallery, Channel, Playlist, Live Stream: version: 13.3.1, author: Embed Plus for YouTube Team
    FancyBox for WordPress: version: 3.2.7, author: Colorlib
    GDPR Cookie Consent: version: 1.8.8, author: WebToffee
    Google Fonts Typography: version: 2.0.4, author: Fonts Plugin
    Host Google Fonts Locally: version: 1.0.3, author: Fonts Plugin
    No Category Base (WPML): version: 1.3, author: Marios Alexandrou
    Official Facebook Pixel: version: 2.0.2, author: Facebook
    Site Kit by Google: version: 1.8.1, author: Google
    SiteOrigin CSS: version: 1.2.7, author: SiteOrigin (latest version: 1.2.8)
    TinyMCE Advanced: version: 5.4.0, author: Andrew Ozz
    Wordfence Security: version: 7.4.7, author: Wordfence
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-11-12 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 8 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 8 GB
    	imagick::RESOURCETYPE_MEMORY: 4 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.1.1
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-178-generic x86_64
    httpd_software: Apache/2.4.18 (Ubuntu)
    php_version: 7.0.33-0ubuntu0.16.04.14 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 16M
    php_post_max_size: 16M
    curl_version: 7.47.0 OpenSSL/1.0.2g
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.30-0ubuntu0.16.04.1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/www.lejongapet.se/wp-content
    WP_PLUGIN_DIR: /var/www/www.lejongapet.se/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### google-site-kit ###
    
    version: 1.8.1
    php_version: 7.0.33-0ubuntu0.16.04.14
    wp_version: 5.4.1
    reference_url: https://www.lejongapet.se
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    active_modules: site-verification, search-console, analytics
    required_scopes: 
    	openid: ✅
    	https://www.googleapis.com/auth/userinfo.profile: ✅
    	https://www.googleapis.com/auth/userinfo.email: ✅
    	https://www.googleapis.com/auth/siteverification: ✅
    	https://www.googleapis.com/auth/webmasters: ✅
    	https://www.googleapis.com/auth/analytics: ✅
    	https://www.googleapis.com/auth/analytics.readonly: ✅
    	https://www.googleapis.com/auth/analytics.manage.users: ✅
    	https://www.googleapis.com/auth/analytics.edit: ✅
    search_console_property: https://www.lejongapet.se/
    analytics_account_id: none
    analytics_property_id: none
    analytics_profile_id: none
    analytics_use_snippet: yes
    
    • This reply was modified 1 year, 2 months ago by Jan Dembowski.
    • This reply was modified 1 year, 2 months ago by Jan Dembowski. Reason: Formatting
    • This reply was modified 1 year, 2 months ago by Jan Dembowski.
    Plugin Support Renee Johnson

    (@reneesoffice)

    @turritops thanks so much for these details.

    For the Analytics account and property with the issue, could you confirm the levels of user permissions the Google Account (email) you’re using with Site Kit has under the following in the Admin area of the Analytics account:

    1) Account User Management
    2) Property User Management
    3) View User Management

    Here’s an example of what the permissions screens will look like. If you’d like to provide the three permissions screens via screenshots that would be great too.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @turritops note to please obscure/hide your email if you provide screenshots if there is no name for the user.

    Thread Starter Turritops

    (@turritops)

    Hi @reneesoffice

    Thank you for the reply. Please see:

    https://imgur.com/a/KouhpyO

    Plugin Support Renee Johnson

    (@reneesoffice)

    @turritops many thanks! We’ll share this with the team and update you when we have more information.

    I have the same issue for an Analytics account that was recently transferred to me. The permissions all look correct (as per screenshots above), but I get the same message.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @mattgeri thanks for the info! We’re investigating this currently and trying to recreate the problem on our side to address the issue. Could you share any known details about the account or steps that were taken to transfer the account to you in the Github issue? Would be super helpful!

    Plugin Support Luckyna San

    (@luckynasan)

    @turritops Hello! We released a fix for this issue in the most recent version 1.12.0. Can you please update to the new version and inform us if the issue persists? Thank you.

    Thread Starter Turritops

    (@turritops)

    @luckynasan thank you for the update. I can confirm that Site Kit now works for all sites, thank you! I needed to reset the settings and reconfigure the plugin from start but now everyghing seems to work as it should.

    Thread Starter Turritops

    (@turritops)

    Resolved.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error: User does not have sufficient permissions for this account.’ is closed to new replies.