WordPress.org

Forums

Stream
[resolved] Error Uploading WooCommerce related to stream/connectors/installer.php (10 posts)

  1. TiagoGoncalves
    Member
    Posted 1 year ago #

    When I Try to update from the WooCommerce 2.1.8 to the 2.19 i got this error message:

    Update Plugin
    Downloading update from https://downloads.wordpress.org/plugin/woocommerce.2.1.9.zip…

    Unpacking the update…

    Installing the latest version…

    Removing the old version of the plugin…

    Could not remove the old plugin.

    Plugin update failed.

    Return to Plugins page

    Notice: Undefined offset: 0 in /var/www/miasapro/wp-content/plugins/stream/connectors/installer.php on line 159

    This is the Plugins I am using:

    Akismet by Automattic version 3.0.0,
    ImageMagick Engine by Orangelab version 1.5.1,
    Nginx Helper by rtCamp version 1.8,
    Private Only, Disable Feed by Kate Mag (Pixel Insert) version 3.4,
    Private Only by Kate Mag (Pixel Insert) version 3.4,
    Simple Image Sizes by Rahe version 3.0,
    Stream by X-Team version 1.4.4,
    WooCommerce Gateways Country Limiter by OnTheGoSystems version 1.0.2,
    WooCommerce MailChimp by Adam Anderly version 1.3.1,
    WooCommerce by WooThemes version 2.1.8

    https://wordpress.org/plugins/stream/

  2. TiagoGoncalves
    Member
    Posted 1 year ago #

    I was not able to upload WooCommerce afterwards through the admin panel with Stream deactivated neither. But I did no get any "notice:" message this time .

    I was forced to updated it through FTP.

    I'm a bit afraid to activate Stream again afterwards. Needless to say I love Stream. I think these two plugins match perfectly on a online store in order to track customers logins. It would be cool if you guys could assure the compatibility.

    Thank you!

  3. shadyvb
    Member
    Plugin Author

    Posted 1 year ago #

    Hi @TiagoGoncalves,

    I've just tried to reproduce your error but couldn't using Stream 1.4.4 and updating WooCommerce to the latest version, it happened seamlessly without errors.

    From what i'm seeing in your log, the update didn't really happened, and Stream would probably have nothing to do with that since it hooks AFTER the plugin has been actually updated. Note:
    > Could not remove the old plugin
    > Plugin update failed

    If you can fix that, you'd probably be fine working with Stream afterwords.

  4. shadyvb
    Member
    Plugin Author

    Posted 1 year ago #

    Great to know you've fixed the original issue you were having, and this seems like Stream wasn't able to handle the errornous install attempt, not at all a compatibility issue with Woocommerce.

    /five!

  5. TiagoGoncalves
    Member
    Posted 1 year ago #

    cool! great to know. so let's be back on Stream ;)

  6. TiagoGoncalves
    Member
    Posted 1 year ago #

    Hey again @shadycb!,

    Today i tried to update Stream to its last version and i got exactely the same message:

    Notice: Undefined offset: 0 in /var/www/miasapro/wp-content/plugins/stream/connectors/installer.php on line 159

    on my error_log.txt also says just that:

    [15-May-2014 08:56:06 UTC] PHP Notice: Undefined offset: 0 in /var/www/miasapro/wp-content/plugins/stream/connectors/installer.php on line 159

    I have no idea what it's causing that. I hope this info can be useful to you.

  7. TiagoGoncalves
    Member
    Posted 1 year ago #

    and i will install the plugin via ftp, again. if you have any idea about the cause of this, please share it.

    Thanks!

  8. shadyvb
    Member
    Plugin Author

    Posted 1 year ago #

    I've checked the last time and couldn't either reproduce nor grasp the possible reason for this, update via FTP, and make sure you deactivate/activate the plugin to install any required DB updates, and lets see if that happens again, We'll certainly work with you then to work it out if it still persist.

    /five!

  9. TiagoGoncalves
    Member
    Posted 1 year ago #

    The FTP update and the database update seam to have worked just fine. I will update you here in case i have the same error message on a next plugin update ;) Thanks!

  10. shadyvb
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Stream
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic