WordPress.org

Forums

[resolved] [closed] error uploading photos (13 posts)

  1. l4rry
    Member
    Posted 2 years ago #

    installed wp 3.5 and have been having trouble uploading images. it looks as if it's a setting with my server but not certain:

    “logo1.jpg” has failed to upload due to an error
    The uploaded file could not be moved to /home/xxx/public_html/wp/wp-content/uploads.

    any help is appreciated. thanks.

    **i'd post a link to what i'm attempting but it's 2012 theme with no content... yet. soon, though.

  2. mar1965
    Member
    Posted 2 years ago #

    Hi Larry,

    You are having some permission issues. Check out some of the older posts that contain the recommended solutions involving changing the permissions on your server. For Windows Error The Uploaded File Could Not Be Moved. The solution is the post by Samuel B in response to the poster of the problem.

    Here is another one for Linux server based installations Permissions Problems Uploading Images.

  3. blogjunkie
    Member
    Posted 2 years ago #

    Hi l4rry! I think the problem is with your directory permissions. To test this theory, FTP into your server and change the wp-content/uploads directory to 777 permissions. If you can upload your image that confirms it.

    However, all directories within wp-content should have 755 permissions. Please read this article for more information: http://codex.wordpress.org/Changing_File_Permissions

    Good luck!

  4. l4rry
    Member
    Posted 2 years ago #

    thank you both! this is helpful. i tried to change the permissions of the uploads directory and received the following error:

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/tmp/phpBrFqAg) is not within the allowed path(s): (/home/) in /home/xxx/public_html/wp/wp-includes/functions.php on line 1815
    Dismiss “logo1.png” has failed to upload due to an error
    The uploaded file could not be moved to /home/xxx/public_html/wp/wp-content/uploads.

    not sure where the error above points towards. going to look over both of the articles sent to learn more.

  5. blogjunkie
    Member
    Posted 2 years ago #

    Ok, what this means is that your web host has locked down your site permissions. Unfortunately this means that their permission scheme is something that WordPress cannot work with.

    You should contact them directly and ask them to allow 755 permissions in your WordPress directories. Send them the link to the codex article too.

    *whisper* Better yet, switch hosts! I use Site5, and WordPress has their own recommended hosts list http://wordpress.org/hosting/

  6. l4rry
    Member
    Posted 2 years ago #

    gotcha and thanks for the advice! strangely, they allowed me to install wordpress via their control panel which is where i gathered interest. appreciate your advice/expertise. cheers!

  7. thecraftcorner
    Member
    Posted 1 year ago #

    Hi,

    I followed the advice that seems to be given for this problem, which is to change the permissions from 755 to 777 in the uploads file.

    Solved my problem and the images are now uploading.

    Just one quick question, I am slightly nervous leaving the permissions at 777 as doesn't this leave the site far more vulnerable to attack???

    And I did try and changing it back to 755 after one upload (As was suggested in one comment) but that created the same problem as before.

    Thanks

    Vanessa

  8. schmitzamanda
    Member
    Posted 1 year ago #

    Hello everyone,

    I had a decent time using wordpress for an entire month, while in Korea, documenting my experiences there. I uploaded HUNDREDS of photos with no trouble. My usual method is to make a text post, write about my day/experience, then select several photos, and sit and let them upload. It worked swimmingly.

    Now, I am catching up on some overdue photos. WordPress shows them loading (0-100%) but shows no photos. One time I even got an error message.

    Any clue as to what should I do?

    Thanks!

    Amanda

  9. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @schmitzamanda - could you start a new thread - this one is way outdated and already marked resolved. You can do so here:

    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    Please also include more info in your post:

    http://codex.wordpress.org/Forum_Welcome#Include_as_much_information_as_possible

  10. cybermike
    Member
    Posted 1 year ago #

    I got this error today ([file name]has failed to upload due to an error The uploaded file could not be moved to wp-content/uploads/....).

    The problem - I had run out of disk space in my hosting account! The solution - increased my hosting space (obviously).

    :)

    Michael

  11. Native Imaging
    Member
    Posted 1 year ago #

    I'm still getting this error. Now on over 100 websites since clients have updated to WP 3.6+

    why has this issue been resolved yet?

  12. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @Native Imaging - please start your own thread and stop posting in outdated threads - as posted here:

    http://wordpress.org/support/topic/wp-37-media-upload-not-working?replies=7

  13. Andrew
    Forum moderator
    Posted 1 year ago #

    Please stop posting this in people's threads.

Topic Closed

This topic has been closed to new replies.

About this Topic