Support » Fixing WordPress » error uploading media

  • Suddenly without warning I became unable to upload media to my posts. I installed 3.5 back in December and everything was fine until I tried to upload a post yesterday. A new screen that I had not seen before came up, and when I clicked on “add media” I got the “drop files anywhere to upload” with the “select files” button. When I do that and select the file, it says its starting to upload but stops short and then gives me an “An error occurred in the upload. Please try again later.”

    Of course, when I try again later, I get the same thing happening.

    I’m not a techie, just a user. Are there instructions somewhere I’m not following? And why would this start occuring several weeks after switching over to 3.5–and what was wrong with the old file upload?

    (Goes screaming from the room as if his hair was on fire as if he had any hair…)

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator kmessinger


    Did you add any thing to your site?

    Did you try just dragging the file?

    Did you try the browser uploader (below the drop files area)?

    Nothing added to the site. I’ve had the same media upload screen up until now. It’s a different process which I assume is part of 3.5. All I know is that I went to add an image to the post and I got that new screen and the error message that came with it.

    I’m not quite sure how “dragging” works, but I presume when you say browser uploader you’re talking about the “select files” button?

    I’d like to be able to send you a screen cap of the “upload” in progress, but apparently this forum doesn’t have that capacity.

    Moderator kmessinger


    Drag an image from a folder or desktop into the outlined area and it will upload it. You can also use select. This is the wp loader.
    If you look below the outlined area you should see, “You are using the multi-file uploader. Problems? Try the browser uploader instead.” It also shows the maximum size of image you can upload.

    I wanted you to try that browser.

    That’s not what I’m seeing. That, I think, is what I used to see. Now I have a large, mostly blank page with
    “Insert media” in the upper left hand corner with the choice of “Upload Files” or “Media Library”.

    Then down in the center of the page is “Drop files anywhere to upload” and with “Select Files” in button below it, along with “Maximum upload file size: 64MB” under that.

    When I pick a file, it looks like it’s going to upload but the progress bar never moves, and then it goes to the error message.

    I am completely dead in the water. I have a news item that’s two days old, and one of my contributors is stymied by not being able to upload pics. And I still don’t even know why/what was changed.

    Moderator kmessinger


    Run thru this suggestions. You have a javascript conflict most often caused by a plugin.

    Also please post your ur.

    OK, I’ll go in and start removing and replacing plug-ins…though what frustrates me is that there was a change in the media upload system that was working and the Suddenly Everything Changed.


    Moderator kmessinger


    You have a lot of html errors. The good thing is that they are cascading so when one gets fixed others usually do also.

    Your theme is a premium theme and is supported at, We have no way to support premium themes as we no nothing about what they are doing.

    Check custom contact form plugin – should be version in fact check all plugin as there is a lot of jquery action going on. We’ve come up with some awesome directions to help you debug your jQuery issues:

    OK, so now I feel like someone just parked a prize steer in my front yard and said, have a nice steak. I’m not a butcher. I suppose I could learn to be one. But that’s not what I, nor likely you, would want to learn. Basically, now I need to find a butcher with a sharp knife and, unlike other butchers I have hired in the past, won’t butcher my site now.

    Seriously, thanks for the help.

    Media button doesn’t work when trying to upload files to a post. any remedies out there? I have scanned through here and see that the problem occured with 3.5 upgrade. Any fixes? I am a user and simply would like to upload a PDF to my post and have tried about a dozen times with no success


    Someone suggested that I make sure all of my plugins, and I noticed that “Get the image” needed updating. So I ran the update, and here’s what I got:

    Plugin failed to reactivate due to a fatal error.

    Fatal error: Cannot redeclare get_the_image() (previously declared in /home/roadkill/public_html/wp-content/themes/wp-davinci209/plugins/get-the-image.php:55) in /home/roadkill/public_html/wp-content/plugins/get-the-image/get-the-image.php on line 202

    I don’t know if this is the problem, but it isn’t likely a /good/ thing.

    Moderator kmessinger


    Rename the get-the-image plugin to xget-the-image. That will stop it from loading.

    (a) I don’t know how to do that, and
    (b) don’t I want to make it go, not stop?

    Moderator kmessinger


    I don’t know how to do that

    You use ftp or go to your hosting site and use the file manager they provide.

    don’t I want to make it go, not stop

    You are getting the error because something is wrong with that plugin or the activation. You can also try to install it again and activate it.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘error uploading media’ is closed to new replies.