Error Uploading images, no longer works... (3 posts)

  1. epicrobot
    Posted 6 years ago #

    I have been having problems uploading images to my new blog located at http://www.epicrobot.com/blog. I installed a new theme and it worked fine at first (as you can see as there's already a few images uploaded there).

    I tried to make a new post yesterday which was fine but when I tried to upload an image I got this error:

    The uploaded file exceeds the upload_max_filesize directive in php.ini

    Obviously I'm uploading a small image file so theres no reason why it should throw a max_filesize error because its not a huge file??

    I've searched around and most places recommend changing the php.ini file but I can't find this anywhere. I've tried uploading a phpinfo file (http://www.epicrobot.com/blog/info.php) as it says that the path to my php.ini file is

    Configuration File (php.ini) Path /usr/lib
    Loaded Configuration File /usr/local/lib/php.ini

    This still doesn't help me find it though :<

    I've got shard hosting and I wonder if that's why I can't find it anywhere??

    I know I could just upload images to a folder without using the image uploader but this is a pain :<

    Please help someone?


  2. php.ini is set by your host and that's the reason you don't have access to it; and they probably won't change it for you.

    You can try adding

    define('WP_MEMORY_LIMIT', '64M');

    to your wp-config.php file and see if that bumps the memory up enough. If not, there are ways to bump the memory in htaccess.

  3. lightfoot33
    Posted 6 years ago #

    Hey epicrobot, I was having similar troubles with my inability to access my php.ini file last week. If you want to look at my post about it, someone (RVoodoo) helped walk me through the process of writing my own: http://wordpress.org/support/topic/314805

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic