Support » Plugin: MailPoet 2 » Error Uploading Images

  • Resolved Rob

    (@sachristan)


    I’ve been using MailPoet for years and this is the first time I’ve had problems with it. When I updated to the new version I get this when I try to upload new images.

    Uploading images errors

    Can anyone lead me in the right direction to fixing this?

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • Rob

    (@sachristan)

    The warnings are of every plugin that is installed on my site:

    Notice: Trying to get property of non-object in…

    Plugin Author MailPoet

    (@wysija)

    Go to your MailPoet’s Settings page > Advanced tab > geeky options link and make sure to disable the Debug mode.

    Rob

    (@sachristan)

    It never was on, so this plugin like others just went down hill.

    Rob

    (@sachristan)

    still not fixed.

    Plugin Author MailPoet

    (@wysija)

    We looked at Rob’s web site and the issue has nothing to do with our plugin. Installing an older version still produces those notices. He has a Debug plugin installed that enables error display, hence is why he sees notices. When all plugins are disabled except for MailPoet and Debug, there are no notices shown. The issue is either with one of the other multiple plugins that Rob has enabled on his site or with his WP install.

    There is one thing in common between all those notices: WP’s get_current_screen() function returns null, and when plugin authors fail to check for the returned value and proceed working with what they think is a valid object, a notice is thrown.

    Rob

    (@sachristan)

    I did deactivate DEBUG but the errors continue. I do not have a good opinion of Mailpoet at all.

    Plugin Author MailPoet

    (@wysija)

    Re,

    Here are the notices with with the older version and all other plugins installed (2.7.8):

    …and here’s with MailPoet 2.7.8 and your Debug plugin installed while other plugins deactivated:

    (we redacted some parts to ensure your privacy)

    As evident from the images, notices are thrown even when an older MailPoet 2 version is installed, so it has nothing to do with the version/latest release. Once you disable all plugins (and keep the Debug to ensure that all errors are displayed), there are no notices. We gave you pointers over the support e-mail for where to look for a problem. Feel free to follow them or find another solution that suits you. None of the other 400k customers complained about this issue.

    Best of luck,
    MailPoet Team.

    Rob

    (@sachristan)

    I found a different solution. I am not using mailpoet. I could careless what you think.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.