Support » Plugin: GEO my WordPress » Error upgrading to v3.0.5

  • Resolved PinkishHue

    (@pinkishhue)


    Hello, I have just tried to update to the latest version from an old version (probably not the most recent as it has been a few months since my last update).

    I updated a collection of plugins at the same time, and when the updateas completed my installation became a blank white screen. So then went to my plugins folder via ftp and removed each updated plugin one at a time. When I removed Geomywp the error disappeared, so presumably it was something with this.

    To try and troubleshoot the issue I then manually downloaded the latest version of the plugin and uploaded it via ftp, then when trying to activate I received this error:

    Parse error: syntax error, unexpected '[' in /home/mywebsitenameremoved/public_html/wp-content/plugins/geo-my-wp/includes/admin/pages/tools/class-gmw-update-forms-table.php on line 264

    Hope you can help! Many thanks

    • This topic was modified 2 years, 5 months ago by PinkishHue.
Viewing 1 replies (of 1 total)
  • Plugin Author Eyal Fitoussi

    (@ninjew)

    Hello,

    Looks like your server running PHP 5.3.x. If that’s the case, my advice is to bump the PHP version to at least 5.4 to make GEO my WP or to 7.x to be up to date.

    Otherwise, you can try and solve the error by modifying a line of code:

    open the file geo-my-wp/includes/admin/pages/tools/class-gmw-update-forms-table.php and replace line 264 which should be:
    if ( $addon == 'global_maps' || in_array( $slug, [ 'gmaps_groups', 'gmaps_posts', 'gmaps_friends', 'gmaps_users' ] ) ) {
    with
    if ( $addon == 'global_maps' || in_array( $slug, array( 'gmaps_groups', 'gmaps_posts', 'gmaps_friends', 'gmaps_users' ) ) ) {.

    Save the file and test it again.

    In the last release of GEO my WP I tried to fix all those errors that related to the PHP version. I will add this fix to the next release.

    If there are any other errors let me know and I will look into it.

    But as suggested above, you might want to bump up your PHP version.

    let me know if this helps.

Viewing 1 replies (of 1 total)
  • The topic ‘Error upgrading to v3.0.5’ is closed to new replies.