Support » Installing WordPress » Error upgrading to 2.0.4

  • I try to upgrade to 2.0.4 but I get this message when I run upgrade.php:
    Warning: main(/home/sites/site173/web/weblog/wp-includes/wp-db.php) [function.main]: failed to open stream: Permission denied in /home/sites/site173/web/weblog/wp-settings.php on line 72

    Fatal error: main() [function.require]: Failed opening required ‘/home/sites/site173/web/weblog/wp-includes/wp-db.php’ (include_path=’.:/usr/lib/php’) in /home/sites/site173/web/weblog/wp-settings.php on line 72

    I followed the instructions, uploaded in ASCII – but no success.
    This WP is upgraded from B2 and I think it was this blog I manually had to add some tables in the database, because otherwise the upgrade from B2 wasn’t working. So I figure I have to make some changes again, but ca’nt figure out yet wat’s the problem. Last time I got clear messages about not able to find the specific tables.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I completely removed everything from the server, including all files link wp-config and freshly installed the new version en uploaded the wp-config back. It worked, I had my blog back. Going to the adminsection, I got the message to upgrade, which I did and everything is still working. Put my theme back, no problem

    Looks like some file(s) didn’t make it intact on the first install.

    Please mark this resolved?

    I had an error on following the simplified instructions for an upgrade from 2.0.3. See this page:

    Very bad news. If only things were as simple as the instructions say. Now I, not at all technical, have a broken blog.

    I’d appreciate help. I’d even pay for it (I’ve got other blog work to be done too, like making my Feedburner feed work).

    Following up on my email . . . actually, I can see a wp-config file (and a sample config file) in my FTP. Does that not mean it’s there?

    I wondered if I should reinstall my blog through my web host’s Fantastico?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error upgrading to 2.0.4’ is closed to new replies.