Support » Fixing WordPress » Error Updating to WordPress 4.8.2

  • My auto update from v4.8.1 to 4.8.2 is failing with the following message:

    Downloading update from https://downloads.wordpress.org/release/wordpress-4.8.2-no-content.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Preparing to install the latest version…

    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/setup-config.php

    Installation Failed

    Any ideas what I can do to fix this? Any way to do it without having to go in manually?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Check the file permissions in your web directory tree. They should be 755 (directories) and 644 (files), owned by the same user under which PHP is running.

    sorry, wrong topic

    • This reply was modified 2 years, 7 months ago by Sonika.

    I have the exact same error. All files and directories in the wp-admin folder have permissions 705, with the exception of setup-config.php which has 644. The error message I get is the same as User sewbon lists above. Does the error message mean that setup-config.php should have the same permissions as the rest of the items in the wp-admin folder, hence 705, that all the files and directories need to be identical, or what?

    FYI, I’ve never changed any permissions ever, so I presume this means they are the default from installation or from a previous upgrade cycle.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Files should be 644, directories 755, with ownership belonging to the user under which PHP is running.

    Thanks Steve. I’ll give it a try. 🙂

    PS If I didn’t change them, how could the permissions settings have gotten to the state they’re in?

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    re your PS: No idea, unless you have been messing with the FS settings in wp-config.php (or your host has changed something). https://codex.wordpress.org/Editing_wp-config.php#Override_of_default_file_permissions

    Thanks Steve: supplementary question. I was asking about the files in my wp-admin directory. I changed every directory and sub-directory to 755, and every file to 644 in that wp-admin directory. Just tried to update again and got the same error message. At the risk of asking the obvious, your suggestion about permissions (775 for directories, 644 for files) should apply to all directories and files everywhere, not just wp-admin? The other top level directories I see are wp-content and wp-includes.

    And no (looking at the suggested link), I haven’t been messing with the FS settings in wp-config.php, unless it was somehow accidentally without realising it.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Is the file ownership consistent through your directories?

    The setup-config.php file is blank (0 file size), and has Owner/Group 0 0. All other files have the same Owner/Group, a numeric string of 7 digits <space> 6 digits.

    Yes. With the exception of the setup-config.php in the wp-admin directory, which has Owner/Group 0 0, all other files appear to have the identical owner code, the same numeric string of 7 digits <space> 6 digits.

    How do I change the ownership of the setup-config.php file from 0 0 to my 7 digits <space> 6 digits string? Can I delete the file and have it automatically re-created? Can I replace it with a “clean” version from somewhere? Any other options?

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Download a new copy of WP from wordpress.org and replace it. If the permissions/ownership is not fixed, please contact your host.

    Downloaded a new copy of WP from wordpress.org; deleted the old copy of setup-config.php from the site; uploaded a new copy of setup-config.php — it loaded with my 7 digits <space> 6 digits owner/group string. Interestingly, it also loaded with permissions set to 604. I changed that to 644. 😉 I then went to my admin panel and ran the update to 4.8.2 … and it worked. Many thanks for all your help! 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error Updating to WordPress 4.8.2’ is closed to new replies.